LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
LinkBack Search this Thread
Old 12-14-2011, 02:49 AM   #1
adamalic
LQ Newbie
 
Registered: Dec 2011
Posts: 2

Rep: Reputation: Disabled
Server Hung due to hda: status timeout: status=0xd0 { Busy }


My Server RedHat EL5.4 hang up and i found folliwing messages below in /var/log/messages, Please tell me the actual reason and its solution: Thanks

Dec 9 16:25:58 Myserver kernel: hda: status timeout: status=0xd0 { Busy }
Dec 9 16:25:58 Myserver kernel: hda: status timeout: status=0xd0 { Busy }
Dec 9 16:25:58 Myserver kernel: ide: failed opcode was: unknown
Dec 9 16:25:58 Myserver kernel: ide: failed opcode was: unknown
Dec 9 17:01:15 Myserver syslogd 1.4.1: restart.
 
Old 12-14-2011, 04:24 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Short answer - we don't know. Not enough info. What can you validate?
Going on the limited information provided, it may be a chipset error, a disk error, cable. I had a system once which couldn't drive the ide bus. When warm I would occasionally get on stdout
hda: not ready
hdb: not ready
and it would sit there, unable to shutdown or anything. Shutdown was, after all, on the disk. To judge by the times
Quote:
Dec 9 16:25:58 Myserver kernel: ide: failed opcode was: unknown
Dec 9 17:01:15 Myserver syslogd 1.4.1: restart.
something similar may be happening.
 
Old 12-14-2011, 04:33 AM   #3
adamalic
LQ Newbie
 
Registered: Dec 2011
Posts: 2

Original Poster
Rep: Reputation: Disabled
hda: status timeout: status=0xd0 { Busy ),

This hda is a CD-ROM drive in my system, which dma is enable in the BIOS, but Kernel is disabling it and I want to disable Polling Media, So how can i update /etc/rc.local file to stop media polling.
 
Old 12-15-2011, 01:27 PM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Something in the back of my mind reminds me of a kernel option if you see a message like that.

Nearly everything is on the new drivers and sda, sdb, etc. Are you using the old driver for some reason? Bear in mind, also that cdroms are not as capable as hard disks; they don't have to be in most cases because of the read speed.
check
hdparm -I /dev/hda |less
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel: hda: irq timeout: status=0xd0 { Busy } - CDROM Problem? ahpin Linux - Hardware 1 08-11-2009 11:24 AM
hdc: status timeout: status=0xd0 { Busy } bagra Linux - Newbie 6 06-12-2009 01:15 PM
hda: irq timeout: status=0xd0 { Busy } maxy7710 Linux - Newbie 4 03-22-2009 06:34 AM
hda:status timeout:status = 0xd0 {Busy} dahlinkj Linux - Newbie 2 05-27-2008 05:36 PM
QTParted Status is Busy is this normal cheetahman Linux - Software 12 08-13-2005 09:00 PM


All times are GMT -5. The time now is 02:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration