LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 10-25-2005, 05:38 PM   #1
fireman949
Member
 
Registered: Dec 2003
Location: Walls
Distribution: Slackware 10.1;CentOS 4
Posts: 51

Rep: Reputation: 15
Samba WinXP roaming profile not loaded because folder exists with incorrect security.


Sorry my title could not be more descriptive.


I have made great strides since this post and now I'm at a point where everything is working correctly, however I have one minor issue that I wondered if anyone has dealt with and how to get around it.


Running RHEL 3, Samba3 connected to a corporate active directory under Windows 2000 with multiple users, roaming profiles and home directories.

The "member server" has been created and is joined to the domain. Users accounts are added to the Linux box if we want them to be able to mount home directories and roaming profiles from that box. Everything works as it should except roaming profiles.

When the user 'joe' logs into the WindowsXP box (joined to W2k active directory), he gets the following message:

Quote:
Windows did not load your profile because a server copy of the profile folder already exists that does not have the correct security. Either the current user or the administrator's group must be the owner of the folder.
I did some googleing and found this helpful hint that tells me I have to dissable checking of user ownership of roaming profiles.

I did this and it works, however, I'm going to have a hard time convincing anyone that we should do this to all the computers (not against it, but if I can avoid this, it would be wonderful).

I'm assuming the problem is that Linux does not have the same permissions structure that Windows Active Directory does and that is why we are hitting this road block.

If the login user is "joe" and the Linux user is "joe" where am I missing the ownership?

Last edited by fireman949; 10-25-2005 at 05:40 PM.
 
Old 10-28-2005, 07:52 PM   #2
mhiggins
Member
 
Registered: Feb 2004
Posts: 140

Rep: Reputation: 15
There are a few ways to solve this problem.

1) Create a logon script that will set the reg setting.
2) Use a Default User profile in netlogon and a ntconfig.pol to set this policy. Each new user will grab the "Default User" as the basis for there profile. The ntconfig.pol file can be create with the same plicy editor described in the above link.

-Matt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disable samba roaming profile egyptian Linux - Networking 1 08-04-2004 04:06 PM
Connecting with Samba to Win2k3 Roaming Profile UltimatePower Linux - Networking 1 08-04-2004 02:33 PM
Samba - Roaming profile problem wimdeg Linux - Software 3 11-03-2003 06:24 AM
Samba - Roaming Profile problem wimdeg Linux - Software 0 11-02-2003 03:39 PM
Roaming Profile Problem with Samba JoshT Linux - Networking 0 01-15-2003 01:52 PM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration