LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices



Reply
 
Search this Thread
Old 09-28-2006, 12:33 PM   #1
bobb_roof
LQ Newbie
 
Registered: Sep 2006
Posts: 17

Rep: Reputation: 0
samba not visible


after configuring samba, i just cannot see it in the linux enterprise 4 machine. this samba server is in the windows 2003 LAN and configured to intergrate with the windows LAN (winbind,krb5,pam,etc). the strange thing here is that i can see this samba server from the windows machines within the LAN but (in the samba server)when I click Application->System Settings->Server Settings->Samba nothing ever comes up.
the smb,nmb,and wins services are well started from the command line. and I believe samba file is well configured.
how do i view this samba server in graphic mode?
 
Old 09-29-2006, 05:25 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
can you ping each machine
can you mount windows shares?
is your samba server in an AD?
can you use the search in windows to locate the samba server by its IP Address?
what shows on the rhel system
Code:
chkconfig --list smb

and 

service smb status

also what happens if you issue the command

smbclient -L 127.0.0.1 (when prompted for pw just press enter)
 
Old 09-30-2006, 01:50 AM   #3
bobb_roof
LQ Newbie
 
Registered: Sep 2006
Posts: 17

Original Poster
Rep: Reputation: 0
thanks odcheck, below are the answers to your questions:

1,can you ping each machine =
yes any machine can ping any in te network including the samba.

2,can you mount windows shares? =
No, i just cannot see any windows machine from the samba server. (i.e when i click: Applications-> Network Servers, small windows appears with WINDOWS NETWORK icon and when i double click on it nothing ever happens).

3,is your samba server in an AD? =
Yes, the samba server has been successfully joined to the w2k3 AD domain.

4,can you use the search in windows to locate the samba server by its IP Address? =
No, when i search with ip address it returns no result but when i search with netbios name it finds and displays the samba server.

what shows on the rhel system
Code:
5,chkconfig --list smb =
bash: chkconfig: command not found
6,and service smb status =
bash: service: command not found
7,also what happens if you issue the command smbclient -L 127.0.0.1 (when prompted for pw just press enter)=
Anonymous login successful
Domain=[ABLECREATION] OS=[Unix] Server=[Samba 3.0.10-1.4E.9]

Sharename Type Comment
--------- ---- -------
homes Disk Home Directories
netlogon Disk Network Logon Service
tmp Disk Temporary file space
IPC$ IPC IPC Service (Samba Server)
ADMIN$ IPC IPC Service (Samba Server)
CanonPrinter Printer CanonPrinter
Anonymous login successful
Domain=[ABLECREATION] OS=[Unix] Server=[Samba 3.0.10-1.4E.9]

Server Comment
--------- -------
LONDON Samba Server

Workgroup Master
--------- -------
ABLECREATION LONDON
yes thats it Mr ODCHECK. and one more thing; the name of this linux/samba machine is London. and the domain is ABLECREATION
 
Old 09-30-2006, 03:16 PM   #4
parveengar
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by bobb_roof
after configuring samba, i just cannot see it in the linux enterprise 4 machine. this samba server is in the windows 2003 LAN and configured to intergrate with the windows LAN (winbind,krb5,pam,etc). the strange thing here is that i can see this samba server from the windows machines within the LAN but (in the samba server)when I click Application->System Settings->Server Settings->Samba nothing ever comes up.
the smb,nmb,and wins services are well started from the command line. and I believe samba file is well configured.
how do i view this samba server in graphic mode?

Run the following command

smbclient -L hostname(FQDN of samba server) -N

It should show all samba shared directories. If it is ur samba server is correctly configured otherwise not.

parveen garg
 
Old 10-01-2006, 05:48 AM   #5
SVP
LQ Newbie
 
Registered: Oct 2006
Posts: 1

Rep: Reputation: 0
Question Wireless installation help needed

Does anyone know how to install wireless card.
I have got a labtop. I intall Fedora Core 5 on. Evrything work fine except for my build in wireless (Athoros Ar5004)
if anyone know the driver to it please tell me.
Thanks!
 
Old 10-01-2006, 10:51 AM   #6
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
@SVP
eveything alright so far? Is it your thread? Not a chatroom here... sorry. But better open your own thread.

@bobb_roof
If its an redhat enterprise system then you must have the commands chkconfig and service (did you run them as root?) and try form /sbin/chkconfig and /sbin/service

--- So strange is that you can see him over netbios (the LONDON) but not via IP even if you can ping him.

perform a smbclient -L ip-address from a windows system then you'll see the shares of it. Next try as root from the console:
mount -t cifs //ipadress of win/winsharename /mnt/mountpoint -o username=winusername,password=winpassword

if cifs doesn't work as FS then try smbfs
So you should be able to mount a win share from cli.
 
Old 10-02-2006, 01:14 PM   #7
bobb_roof
LQ Newbie
 
Registered: Sep 2006
Posts: 17

Original Poster
Rep: Reputation: 0
when i run the command:

smbclient -L london@ablecreation.com -N

(on the samba machine) it says:

Unknown parameter encountered: "netbios"
Ignoring unknown parameter "netbios"
Connection to london@ablecreation.com failed

this according to you is improper configuration, so how do i fix this?
I want you to understand that this is not just a samba set up. its a winbind integrated environment. authentication of all the LAN workstations are intended to take place in the ADS which is in a w2k3 server. files configured are:
Krb5-workstation
Krb5-libs
Pam_krb5
Samba-commons
Samba
NTP
And below are the changes in these files:

(1)krb5.conf:
[logging]

default = FILE:/var/log/krb5libs.log

kdc = FILE:/var/log/krb5kdc.log

admin_server = FILE:/var/log/kadmind.log

[libdefaults]

default_realm = ABLECREATION.COM

dns_lookup_realm = true

dns_lookup_kdc = true

[realms]

ABLECREATION.COM = {

kdc = w2k3dc.ablecreation.com:88


admin_server = w2k3dc.ablecreation.com:749

default_domain = ablecreation.com

}

[domain_realm]

.ablecreation.com = ABLECREATION.COM

ablecreation.com = ABLECREATION.COM

[kdc]

profile = /var/kerberos/krb5kdc/kdc.conf

[appdefaults]

pam = {

debug = false

ticket_lifetime = 36000

renew_lifetime = 36000

forwardable = true

krb4_convert = false

}

(2)nsswitch.conf:
passwd: files winbind

shadow: files winbind

group: files winbind

protocols: files winbind

services: files winbind

netgroup: files winbind

automount: files winbind

(3)system-auth (in /etc/pam.d directory):
auth required /lib/security/$ISA/pam_env.so

auth sufficient /lib/security/$ISA/pam_unix.so likeauth nullok

auth sufficient /lib/security/$ISA/pam_krb5.so use_first_pass

auth sufficient /lib/security/$ISA/pam_winbind.so use_first_pass

auth required /lib/security/$ISA/pam_deny.so

account required /lib/security/$ISA/pam_unix.so broken_shadow

account sufficient /lib/security/$ISA/pam_succeed_if.so uid < 100 quiet

account [default=bad success=ok user_unknown=ignore] /lib/security/$ISA/pam_krb5.so

account [default=bad success=ok user_unknown=ignore] /lib/security/$ISA/pam_winbind.so

account required /lib/security/$ISA/pam_permit.so

account requisite /lib/security/$ISA/pam_succeed_if.so user ingroup unix

password requisite /lib/security/$ISA/pam_cracklib.so retry=3

password sufficient /lib/security/$ISA/pam_unix.so nullok use_authtok md5 shadow

password sufficient /lib/security/$ISA/pam_krb5.so use_authtok

password sufficient /lib/security/$ISA/pam_winbind.so use_authtok

password required /lib/security/$ISA/pam_deny.so

session required /lib/security/$ISA/pam_limits.so

session required /lib/security/$ISA/pam_unix.so

session optional /lib/security/$ISA/pam_mkhomedir.so skel=etc/skel/ umask=0027

session optional /lib/security/$ISA/pam_krb5.so

(4)smb.conf:
[global]

workgroup = ABLECREATION

netbios name = London

server string = Samba Server

security = ads

realm = ABLECREATION.COM

encrypt passwords = yes

smb passwd file = /etc/samba/smbpasswd

allow trusted domains = yes

unix password sync = Yes

passwd program = /usr/bin/passwd %u

passwd chat = *New*password* %n\n *Retype*new*password* %n\n

*passwd:*all*authentication*tokens*updated*successfully*

pam password change = yes

obey pam restrictions = yes

socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

dns proxy = no

idmap uid = 16777216-33554431

idmap gid = 16777216-33554431

winbind use default domain = yes

winbind separator = #

winbind enum users = yes

winbind enum groups = yes

template shell=/bin/bash

template homedir = /home/%U

Is anything wrong in any of these fileds?
 
Old 10-02-2006, 10:33 PM   #8
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
forget this it's just smbclient -L london and no need of -N option not the full qualified domain name.
 
Old 10-03-2006, 04:44 AM   #9
bobb_roof
LQ Newbie
 
Registered: Sep 2006
Posts: 17

Original Poster
Rep: Reputation: 0
yes when i type:
smbclient -L london
i recieve:
Unknown parameter encountered: "netbios"
Ignoring unknown parameter "netbios"
Password:
Anonymous login successful
Domain=[ABLECREATION] OS=[Unix] Server=[Samba 3.0.10-1.4E.9]

Sharename Type Comment
--------- ---- -------
homes Disk Home Directories
netlogon Disk Network Logon Service
tmp Disk Temporary file space
IPC$ IPC IPC Service (Samba Server)
ADMIN$ IPC IPC Service (Samba Server)
CanonPrinter Printer CanonPrinter
Anonymous login successful
Domain=[ABLECREATION] OS=[Unix] Server=[Samba 3.0.10-1.4E.9]

Server Comment
--------- -------
LONDON Samba Server

Workgroup Master
--------- -------
ABLECREATION

i think it now displays the work group,shares,and stuffs (in the shell prompt). but the original problems remains. ie:

(1)i can see this samba machine (London) from windows machines but when i click to browse it it says:
\\London is not accessible. You might not have the permission to use this network resource. Contact the administrator of this Server to find out if you have access permissions.
The network path was not found.

(2a)on the samba machine (London),when i click Application->Network Servers-> and double click windows network, nothing ever shows up.
(2b)on the samba machine (London), when i click Application->System settings->Server settings->Samba and and enter root password nothing ever comes up.
whats the way out?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba: Only first letter of shared files visible betonarbejder Linux - Networking 0 09-25-2006 04:18 PM
Samba XP shares: Only first 36 folder visible in Konqueror sugna Linux - Software 1 07-04-2005 08:59 AM
samba: home directories not visible flipboi Linux - Networking 1 05-28-2004 12:06 AM
Samba share not visible kochuthara Linux - Software 5 02-25-2004 04:04 AM
PRINTER visible, but can't print (samba on RedHat 8.0) jaitropfaim Linux - Hardware 0 02-17-2003 04:37 PM


All times are GMT -5. The time now is 11:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration