LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 11-05-2008, 09:34 AM   #1
balamuruganm
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Rep: Reputation: 0
RHEL v4 - How to enable graphical mode?


Hi

I have installed RHEL v4 AS in Intel Server.

I tried to install Websphere Application Server 6.0. On starting the install the installer terminates with error
“The installer is unable to run in graphical mode. Try running the installer with the -console or -silent flag.“

How do I enable the graphical mode in the RHEL v4 AS?

Please let me know if you need further details.

Thanks
 
Old 11-05-2008, 11:17 AM   #2
bhaslinux
Member
 
Registered: Oct 2003
Location: UnitedKingdom
Distribution: Debian Lenny
Posts: 351

Rep: Reputation: 47
Did you start the installer in the Xwindow session ?
If yes is the environment variable DISPLAY set in the shell ?
 
Old 11-05-2008, 12:28 PM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
And if you're doing it remotely, by ssh'ing into the server, you need to set X forwarding with the -X flag when you ssh into the machine.

But yeah, if X isn't even installed like most server classed machines should be setup, use the -console option to run it from the command line to install.
 
Old 11-05-2008, 10:42 PM   #4
balamuruganm
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Hi

Thanks for the reply. X11 has been installed in the server.

I used putty to connect using SSH and enabled X11 forwarding.

I tried xclock and got the error
X connection to localhost:10.0 broken (explicit kill or server shutdown).

I did some search in the net and understood that the error is because I am trying to open the X11 window from another system.

So I executed this command
xterm -display 10.105.146.28:0 where 10.105.146.28 is the system IP from where I am accessing the server

But this still gives error

Warning: This program is an suid-root program or is being run by the root user.
The full text of the error or warning message cannot be safely formatted
in this environment. You may get a more descriptive message by running the
program as a non-root user or by removing the suid bit on the executable.
xterm Xt error: Can't open display: %s


Please help.

Thanks
 
Old 11-05-2008, 10:47 PM   #5
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Does the RH box have X or any other gui related software installed? Probably not.
 
Old 11-05-2008, 10:58 PM   #6
balamuruganm
LQ Newbie
 
Registered: Nov 2008
Posts: 3

Original Poster
Rep: Reputation: 0
How can I check that? Can you please provide me the commands.

The installation of RHEL was done through GUI only. So I guess that some graphical display software also would have been installed.

Thanks
 
Old 11-05-2008, 11:29 PM   #7
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Someone else can comment, since I don't use X forwarding, but I assume the server would need it installed. Just because the installer was graphical is irrelevant.

I would assume that you would have a directory /etc/X11 if X is installed.

Clearly you could use rpm to check as well, but I don't have any package names at hand for you to check.

Rgds
 
Old 11-06-2008, 04:37 AM   #8
DT0X
LQ Newbie
 
Registered: Nov 2008
Location: South-West UK
Distribution: Fedora, RHEL 4 and 5, Ubuntu 7 and AIX
Posts: 12

Rep: Reputation: 0
I don't know if this is something obvious that you've already tried - if so, sorry! This is my first post after all...

If your running the installer remotely:

1. SSh into the box with the following: ssh -X ip_address_of_server
2. Make sure the client box you are on has an xserver that can accept the x session from the ssh destination (sounds like this could be your problem - if so you need a program such as exceed running on your windows / putty box)
3. Export your display: export DISPLAY=ip_address_of_putty_box:0.0
4. Fire up xclock to test the x connection

I would install the software from the local console if I was you though (if you have access to one that is) that will rule out any remote X issues for now.

Last edited by DT0X; 11-06-2008 at 04:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to enable graphical mode for ubuntu 8.04 kedidie Linux - Newbie 7 07-07-2008 10:26 AM
LXer: Howto Boot debian in text mode instead of graphical mode (GUI) LXer Syndicated Linux News 0 09-09-2007 07:41 PM
convert text mode linux OS to graphical mode csaju Linux - Newbie 1 10-09-2006 05:18 AM
From console mode to x graphical mode gubak Linux - Newbie 3 12-13-2005 04:18 PM
How to; Suse9.3 prof. text mode to graphical mode anjum Linux - Software 5 07-20-2005 11:36 PM


All times are GMT -5. The time now is 10:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration