LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 08-25-2006, 09:22 AM   #1
mastermatics
LQ Newbie
 
Registered: Aug 2006
Location: india
Posts: 2

Rep: Reputation: 0
Post Rhe:iowait


I run a REDHAT Enterprise version server which is used as a hosting server with around 200 domains setup on it, of late i have noticed that the IOWAIT is taking up a lot of resources therby pushing up the CPU load to 2.5+ and sometimes going up to even 9.0.
I have ClamAV and Spamassassin installed besides the ususal PHP,MySQL.
Can anyone suggest whats the cause for a high IOWAIT and what steps needs to be taken to reduice this.

thnx
samir
 
Old 08-26-2006, 02:35 AM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,354

Rep: Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042Reputation: 1042
Mmmm - I/O maybe ???.
I don't understand what you mean by this ...
Quote:
of late i have noticed that the IOWAIT is taking up a lot of resources therby pushing up the CPU load to 2.5+ and sometimes going up to even 9.0.
The load ave is (at best) only a poor indicator of work queued for CPUs. If you have a lot of IOWAIT, it's even worse.
Best to concentrate on sorting out your disk farm - RHEL should include the sysstat package - check the admin guide for some pointers on what to look for.

Actually I seem to remember a thread a while back about a problem just like this on RHEL - try a search here on LQ.
 
Old 08-26-2006, 06:18 AM   #3
mastermatics
LQ Newbie
 
Registered: Aug 2006
Location: india
Posts: 2

Original Poster
Rep: Reputation: 0
Thnx Syg00, i meant I/O as you rightly pointed out.
I will check the fdisk output to see if it throws up anything.
I did check out the other psots on this topic, but it wasnt too helpful, hence created a new thread.
Actually the server was running fine till a few weeks back, when we installed a chkusr patch basically to delete mails not intended for recepients on the server, thats when the CPU started showing increased loads. My admin guys tell me the qmail-scanner could be a probable cause, i dunno, i am pretty lost out here, since the server is 2.5 yrs old and hasnt given any trouble so far

thnx
samir
 
  


Reply

Tags
redhat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is iowait? mynameisjohnny Linux - Newbie 2 07-27-2010 05:23 AM
high iowait in RHES sklam Red Hat 20 12-14-2006 12:35 PM
Iowait ashley75 Linux - General 25 02-11-2006 11:41 PM
CPUs in high IOwait state despite of lack of load kvsraju Linux - Enterprise 3 11-03-2005 03:34 PM
RHE, Ensim Basic for RHE, Plesk for RHE xbaez Linux - Software 0 09-21-2004 09:45 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration