LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 01-27-2013, 11:09 PM   #1
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Rep: Reputation: Disabled
Exclamation Please help. yum not wokring


[root@pmd HadGEM]# yum install glibc-devel
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
http://10.0.0.1/repos/1000/Server/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (111, 'Connection refused')>
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: kusu-installer-Server. Please verify its path and try again
[root@pmd HadGEM]# uname -a
Linux pmd.pakmet.com 2.6.18-128.el5 #1 SMP Wed Dec 17 11:41:38 EST 2008 x86_64 x86_64 x86_64 GNU/Linux
[root@pmd HadGEM]#
 
Old 01-28-2013, 03:33 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
so HAVE you verified the path?? someone has clearly set up a local server in your LAN, on 10.0.0.1 so there's probably an isseu with that, or reaching it.

BTW, just dumping console output and thinking it alone makes a good post on a forum.. nope. you need to actually give us some context, what you've already tried etc.
 
Old 01-28-2013, 03:40 AM   #3
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
Dear Chris
Actually its a cluster system installed using Platform cluster manager, 10.0.0.1 is the default gateway ip of cluster. Please have a look at below file

[root@pmd pmdtest]# vi /etc/yum.repos.d/kusu-installer.repo
[kusu-installer-Server]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/Server
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-Cluster]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/Cluster
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-ClusterStorage]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/ClusterStorage
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-VT]
name=Kusu installer rhel 5 x86_64
"/etc/yum.repos.d/kusu-installer.repo" 28L, 702C
[kusu-installer-Server]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/Server
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-Cluster]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/Cluster
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-ClusterStorage]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/ClusterStorage
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU

[kusu-installer-VT]
name=Kusu installer rhel 5 x86_64
baseurl=http://10.0.0.1/repos/1000/VT
enabled=1
gpgcheck=0
gpgkey=http://10.0.0.1/repos/1000/RPM-GPG-KEY-KUSU
I have another backup cluster on which same yum.conf file is present with ip 20.0.0.1 and the yum is working fine there
 
Old 01-28-2013, 03:44 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
well we don't have ANY idea how your internal repos work (or don't work). We can't tell you what ip to use.
 
Old 01-31-2013, 04:46 AM   #5
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
10.0.0.1 is the IP of the server itself, the problem comes with reaching it. any suggestions.
 
Old 01-31-2013, 04:50 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
yes, look at that server. this is VERY clearly NOTHIGN to do with yum. It's YOUR server that YOU set up to host a repo. Fix it, or the generic networking to it.
 
Old 01-31-2013, 05:05 AM   #7
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
Dear Chris

Consider me a newbie or not an expert to such a level. I didn't set up anything as I said all this settings are by default I just defined network IP of this cluster during installation (i.e 10.0.0.0).
To test this I have built another cluster with the network ID 20.0.0.0 and there the yum is working successfully.
[root@pmd ~]# wget http://10.0.0.1/repos/1000/Server/repodata/repomd.xml
--07:59:30-- http://10.0.0.1/repos/1000/Server/repodata/repomd.xml
Connecting to 10.0.0.1:80... failed: Connection refused.
[root@pmd ~]#

[root@pmd02 pmdtest]# wget http://20.0.0.1/repos/1000/Server/repodata/repomd.xml
--09:09:38-- http://20.0.0.1/repos/1000/Server/repodata/repomd.xml
Connecting to 20.0.0.1:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1158 (1.1K) [text/xml]
Saving to: `repomd.xml'

100%[=======================================>] 1,158 --.-K/s in 0s

09:09:38 (368 MB/s) - `repomd.xml' saved [1158/1158]
 
Old 01-31-2013, 05:14 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
"you" doesn't necessarily mean you as a person. You have non-default config from a distro perspective. someone has changed that configuration outside of anything official. If it wasn't you personally, go find the guy that did do it, or may know something about that server or the network infrastructure within which is resides for assistance. There settings are NOT by default.
 
Old 01-31-2013, 10:25 PM   #9
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
I know this is not the default config from the Redhat. But I think during cluster installation it is default configuration, as I am the person who installed this cluster and then didnt change any thing. Just to add the following path and xml is present.
/repos/1000/Server/repodata/repomd.xml
 
Old 01-31-2013, 11:20 PM   #10
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
Chris what I did now is edited my kusu-installer.repo with baseurl as follows

[kusu-installer-Server]
name=Kusu installer rhel 5 x86_64
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/$basearch/Debuginfo/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[kusu-installer-Cluster]
name=Kusu installer rhel 5 x86_64
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/$basearch/Debuginfo/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[kusu-installer-ClusterStorage]
name=Kusu installer rhel 5 x86_64
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/$basearch/Debuginfo/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

[kusu-installer-VT]
name=Kusu installer rhel 5 x86_64
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/5Server/en/os/$basearch/Debuginfo/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

Now yum update worked, but I am not able to find any package
like [root@pmd yum.repos.d]# yum install glibc-devel
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Parsing package install arguments
No package glibc-devel available.
Nothing to do
[root@pmd yum.repos.d]# yum list glibc-devel
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Error: No matching Packages to list
[root@pmd yum.repos.d]#


Although I installed this package on the other system at the same time

[root@pmd02 pmdtest]# yum reinstall glibc-devel.i386
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Reinstall Process
Resolving Dependencies
--> Running transaction check
---> Package glibc-devel.i386 0:2.5-34 set to be erased
---> Package glibc-devel.i386 0:2.5-34 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
glibc-devel i386 2.5-34 kusu-installer-Server 2.0 M
Removing:
glibc-devel i386 2.5-34 installed 4.6 M

Transaction Summary
================================================================================
Install 1 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Total download size: 2.0 M
Is this ok [y/N]: y
Downloading Packages:
glibc-devel-2.5-34.i386.rpm | 2.0 MB 00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : glibc-devel [1/2]
Installing : glibc-devel [1/2]

Removed: glibc-devel.i386 0:2.5-34
Installed: glibc-devel.i386 0:2.5-34
Complete!
[root@pmd02 pmdtest]#
 
1 members found this post helpful.
Old 02-01-2013, 02:14 AM   #11
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
why are you showing me that? I don't understand what you don't understand here.

those repos you listed all have the SAME url...?!?! AND that URL only contains debug info pacakges which you'll probably never have any use for.

And clearly you are still using a different configuration on both boxes, otherwise they'd both have a valid place to install files from.
 
Old 02-01-2013, 03:05 AM   #12
ahsanpmd
LQ Newbie
 
Registered: Oct 2012
Posts: 28

Original Poster
Rep: Reputation: Disabled
Sorry for the all the messup.
My point is I want from yum working. If my path or /etc/yum.repos.d/kusu-installer.repo file is wrong what you advise me to do to make it work.
 
Old 02-01-2013, 03:27 AM   #13
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
you need to use a working repo server! and this is all on YOUR servers, I don't work with you. I can't tell you what internal server to use!
 
Old 02-10-2013, 11:45 PM   #14
smbhandary
LQ Newbie
 
Registered: Jan 2013
Distribution: RHEL and AIX ( sort of )
Posts: 18

Rep: Reputation: Disabled
per my understanding of the problem statement.

1. check on and fix the SELinux configuration on the repo server and repo client if applicable.
2. check on and fix the firewall configuration on the repo server and repo client if applicable.
3 ensure the repo server is pingable from the repo client.
4. ensure that port 80 is being listened on on the repo server and that requests from the repo client reach the port.
5. Check on the permissions of the repo resource in focus from the mount point up.
5. Check on / compare the http / network / SELinux / firewall / yum configurations on the working and non working repo clients.

Yum will say " nothing to install " if it sees that the package in focus is already installed and will reinstall a package that is already installed. ie a install is not the same as a reinstall.

Is there a reason " yum install glibc-devel " is expected to behave the same as " yum reinstall glibc-devel.i386 " ?

Last edited by smbhandary; 02-11-2013 at 12:13 AM. Reason: improvements...
 
Old 12-19-2013, 04:20 AM   #15
balu_therock
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Rep: Reputation: Disabled
Port is not open or firewall might be blocking

Hi ahsanpmd,
I saw your error

Quote:
[root@pmd HadGEM]# yum install glibc-devel
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
http://10.0.0.1/repos/1000/Server/repodata/repomd.xml: [Errno 4] IOError: <urlopen error (111, 'Connection refused')>
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: kusu-installer-Server. Please verify its path and try again
Connection refused means the request is reaching but not able to access because of
Port is not open or firewall might be blocking ... ask network admin at switch level configuration to open the port for http for the server which you are using.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] internet is not wokring deep27ak Solaris / OpenSolaris 9 01-23-2012 07:53 AM
Openvpn with Ethernet is not wokring properly. Timtastic Linux - Server 1 01-31-2010 03:46 AM
Ubuntu 9.04 will update...all fixes not wokring dorlack Linux - Newbie 1 10-19-2009 11:32 AM
qmailrocks smtp auth not wokring posixjunkie Linux - Networking 6 05-08-2004 10:29 AM
Nothing's wokring in Gentoo 1.4rc4! Help! kierl Linux - General 2 07-28-2003 03:42 PM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration