LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
LinkBack Search this Thread
Old 10-07-2010, 11:31 PM   #1
trusst
LQ Newbie
 
Registered: May 2010
Posts: 7

Rep: Reputation: 0
NIS issue


Hi,

I needed to add a new user to our NIS.
Ran adduser, passwd, make -C /var/yp.

I can see user added to /etc/passwd on the NIS server and I can login as that user on the server.

On NIS client I cannot login as the new user, 'ypcat passwd' doesn't show the new account, 'rpcinfo -u localhost ypbind' shows that ypbind is running.

Any ideas what's wrong?

Thank you.
 
Old 10-08-2010, 07:52 AM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 5,772
Blog Entries: 4

Rep: Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697Reputation: 697
It's been several years since I used NIS but it sounds to me like you didn't do the yppush from the NIS master to update the clients after you made the change.
 
Old 10-08-2010, 07:10 PM   #3
trusst
LQ Newbie
 
Registered: May 2010
Posts: 7

Original Poster
Rep: Reputation: 0
I thought that running make will run yppush. Is there a way to verify that running make /var/yp performs all the necessary steps?

Quote:
Originally Posted by MensaWater View Post
It's been several years since I used NIS but it sounds to me like you didn't do the yppush from the NIS master to update the clients after you made the change.
 
  


Reply

Tags
adduser, nis, rhel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NIS Authentication Issue techterling Linux - Server 15 08-17-2010 11:50 AM
NIS issue for solaris 10 UltraSoul Solaris / OpenSolaris 16 05-28-2007 11:27 AM
nis server issue hitesh_linux Linux - Networking 1 07-21-2005 06:51 AM
NIS db issue HeReigns Linux - Networking 0 12-09-2003 01:33 PM
NIS issue HeReigns Linux - General 0 09-19-2003 03:35 PM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration