LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices



Reply
 
Search this Thread
Old 02-18-2005, 11:59 PM   #1
backroger
Member
 
Registered: Dec 2004
Posts: 81

Rep: Reputation: 15
Need help in updating two rpm package.


Okay guys I have this...

[root@eapi etc]# more ld.so.conf
/usr/kerberos/lib
/usr/X11R6/lib
/usr/lib/qt-3.1/lib
/usr/lib/mysql
/usr/lib/libnetsnmp.so.5
/usr/lib/libnetsnmpagent.so.5
/usr/lib/libnetsnmphelpers.so.5
/usr/lib/libnetsmpmibs.so.5
/usr/lib/libsnmp.so.5
[root@eapi etc]# ldconfig
[root@eapi rhel_repository]# ls -la net-sn*
-rw-rw-r-- 1 ogie ogie 730463 Feb 11 11:38 net-snmp-5.0.9-2.30E.12.i386.rpm
-rw-rw-r-- 1 ogie ogie 147530 Feb 18 16:39 net-snmp-utils-5.0.9-2.30E.12.i386.rpm
[root@eapi rhel_repository]# rpm -Uvh net-snmp*.rpm
warning: net-snmp-5.0.9-2.30E.12.i386.rpm: V3 DSA signature: NOKEY, key ID 6d6abdc7
warning: net-snmp-utils-5.0.9-2.30E.12.i386.rpm: V3 DSA signature: NOKEY, key ID 73307de6
error: Failed dependencies:
libnetsnmp.so.5 is needed by net-snmp-5.0.9-2.30E.12
libnetsnmpagent.so.5 is needed by net-snmp-5.0.9-2.30E.12
libnetsnmphelpers.so.5 is needed by net-snmp-5.0.9-2.30E.12
libnetsnmpmibs.so.5 is needed by net-snmp-5.0.9-2.30E.12
libnetsnmp.so.5 is needed by net-snmp-utils-5.0.9-2.30E.12
libnetsnmp.so.5 is needed by net-snmp-utils-5.0.9-2.30E.6
libsnmp.so.5 is needed by (installed) hpoj-0.90-14
Suggested resolutions:
net-snmp-5.0.9-2.30E.6.i386.rpm
[root@eapi etc]# rpm -qa|grep snmp
net-snmp-5.0.9-2.30E.6
net-snmp-devel-5.0.9-2.30E.6
net-snmp-utils-5.0.9-2.30E.6
[root@eapi lib]# ls libnet*
libnetsnmp.a libnetsnmphelpers.la libnetsnmpmibs.so
libnetsnmpagent.a libnetsnmphelpers.so libnetsnmpmibs.so.5
libnetsnmpagent.la libnetsnmphelpers.so.5 libnetsnmpmibs.so.5.0.9
libnetsnmpagent.so libnetsnmphelpers.so.5.0.9 libnetsnmp.so
libnetsnmpagent.so.5 libnetsnmp.la libnetsnmp.so.5
libnetsnmpagent.so.5.0.9 libnetsnmpmibs.a libnetsnmp.so.5.0.9
libnetsnmphelpers.a libnetsnmpmibs.la
[root@eapi lib]# ls -la libsnmp*
-rw-r--r-- 1 root root 676332 Jul 19 2004 libsnmp.a
-rw-r--r-- 1 root root 700 Jul 19 2004 libsnmp.la
lrwxr-xr-x 1 root root 16 Jan 18 08:53 libsnmp.so -> libsnmp.so.5.0.9
lrwxr-xr-x 1 root root 16 Jan 18 08:37 libsnmp.so.5 -> libsnmp.so.5.0.9
-rwxr-xr-x 1 root root 488036 Jul 19 2004 libsnmp.so.5.0.9
[root@eapi lib]#

Anybody have an idea how to install this 2? This is the only 2 package left for me to update.

Last edited by backroger; 02-19-2005 at 02:33 AM.
 
Old 02-19-2005, 04:45 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
that's certianly odd, but afaik rpm is only looking in the rpm database for the files existance, and not actually referring to the filesystem (i hate rpms..). does the rpm database think it's installed? "rpm -qf /usr/lib/libsnmp.so.5"
 
Old 02-21-2005, 12:19 AM   #3
backroger
Member
 
Registered: Dec 2004
Posts: 81

Original Poster
Rep: Reputation: 15
resolved...

It also need the net-snmp-libs.5*.rpm able to update them all.

Thank you very much

Last edited by backroger; 02-21-2005 at 12:22 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dselect - how to update & install a package without updating all others? ryryur Linux - Newbie 2 01-19-2005 12:58 PM
Package Errors After Updating? spaaarky21 Fedora 3 12-04-2004 04:59 PM
Package updating/installing tool in FC1 vharishankar Linux - Software 7 11-29-2004 10:39 AM
can reinstall the rpm package without delete the rpm package eye Red Hat 1 10-20-2003 08:53 AM
Distro with easy package updating via the shell? IceNineJon Linux - Distributions 27 03-05-2003 04:15 AM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration