LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices



Reply
 
Search this Thread
Old 07-17-2006, 05:32 AM   #1
vukhanhthuy
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Looking for Expert on RedHat Cluster Suite 3


I have installed RedHat Cluster Suite on 2 nodes and they are working fine now except one thing. When I reboot the slave node, it returns and takes over the service while the master node does not stop its service. So both nodes take the service together.
Can anyone tell me what is the problem here?
 
Old 07-25-2006, 02:33 PM   #2
mjgsantos
LQ Newbie
 
Registered: Jun 2006
Location: São Paulo - Brazil
Posts: 8

Rep: Reputation: 0
Hello.
I'm not sure, but maybe your slave node is in the 1st place in the failover order, so it tries to take over the service. If the other ser isn't releasing the service, maybe there is also some problem with the script that stops the service and releases the resources. Have you tried to do a service takeover between the nodes to check if it works ok?
I was always advised to not put the cluster services on the server startup process, to avoid this situation, in any kind of OS and cluster service (MS, IBM HACMP, RedHat Cluster, etc...), so I start the cluster daemon only after verifying if the machine is ok.
 
Old 08-06-2006, 12:52 PM   #3
vukhanhthuy
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Hi mjgsantos,

Thanks for advise.
I had solved this. I had assign wrong members ID so that the cluster can not lock the quorrum, then members took the service together. That was my mistake when I created the configuration file manually .
But thank you very much for you reply.

Regards
 
Old 08-09-2006, 01:49 AM   #4
jeflau
LQ Newbie
 
Registered: May 2006
Posts: 3

Rep: Reputation: 0
Dear Sir,
I here would like to get your help on guide me how may I setup the qmail clustering. I do had installed the fedora core 4 + system-config-cluster in two PC. I do plug-in the two PC with cross cable and configure it using the system-config-cluster but fail. May you let me know Fence device for using a cross RJ45 Cable what should I put
 
Old 08-09-2006, 07:36 AM   #5
vukhanhthuy
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Dear jeflau,

For your matter,

Quote:
May you let me know Fence device for using a cross RJ45 Cable what should I put.
I think there's no need to put any Fence device here.


Quote:
I do plug-in the two PC with cross cable and configure it using the system-config-cluster but fail.
Tell me more detail about this.

Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Redhat Cluster suite magobin Linux - Enterprise 0 03-13-2006 07:00 AM
redhat Cluster Suite marpel Red Hat 0 01-19-2006 09:05 AM
RedHat Cluster Suite - No Quorum vamosb Linux - Enterprise 9 12-09-2005 08:16 AM
redhat cluster suite matter comdaze Linux - Software 1 10-20-2005 04:18 AM
redhat cluster suite matter comdaze Linux - Enterprise 0 10-20-2005 12:10 AM


All times are GMT -5. The time now is 05:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration