LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 07-08-2008, 12:47 AM   #1
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Rep: Reputation: 29
jdk-1_5_0_15-linux-i586-rpm


hi,

I have installed the jdk-1_5_0_15-linux-i586-rpm. the way I installed is.

#./jdk-1_5_015-linux-i586-rpm

its says that done sucessfully now when I want to run the greenstone install wizard it won't give me wizard it takes me wait wait and wait. no error nothing i get. jdk is required by greenstone software.

I tried alot to congiure it but no response at all can any body as any link for complete instruction to install jdk properly. I am really stuk with it and I have to give a presentation of my digital library to my agrresive BOSS.


thanks
shahz
 
Old 07-08-2008, 02:19 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Usually their RPM's initially are self extracting. You then need to install the RPM that is extracted. This page might give you some insight to installing Java: http://java.sun.com/javase/6/webnote...all-linux.html

Last edited by trickykid; 07-08-2008 at 02:20 AM.
 
Old 07-08-2008, 03:34 AM   #3
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by trickykid View Post
well when I go through the above link I get an erro while doing the following.

#cd /usr/java/jdk1.6.0/demo/jfc/SwingSet2
#chmod +x SwingSet2.jar
#./SwingSet2.jar

on the third command ./SwingSet2.jar I get the error

"cannot execute binary file"

and again I am stop with everything I was doing

thanks
shahz
 
Old 07-08-2008, 06:07 AM   #4
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by trickykid View Post
well when I go through the above link I get an erro while doing the following.

#cd /usr/java/jdk1.6.0/demo/jfc/SwingSet2
#chmod +x SwingSet2.jar
#./SwingSet2.jar

on the third command ./SwingSet2.jar I get the error

"cannot execute binary file"

and again I am stop with everything I was doing

thanks
shahz
 
Old 07-08-2008, 07:24 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,744

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
To execute a ".jar" file :
'java -jar SwingSet2.jar' (or make a script to execute it)

But what has SwingSet2.jar to do with greenstone ??
I assume the greenstone file is gsdl-2.80-unix.tar.gz or ??

And the command 'sh setupLinux.bin' doesn't work for me either,
pointing or not to java home (or //bin/java ).
Using 1.6.0_04-b12. I intend to test also with an earlier version.

To test if java is present, just do 'java -version'

Rgds
 
Old 07-08-2008, 07:29 AM   #6
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by knudfl View Post
But what has SwingSet2.jar to do with greenstone ??
I assume the greenstone file is gsdl-2.80-unix.tar.gz or ??
well dear I don't get the graphical installation wizard. why I don't get it.
 
Old 07-08-2008, 09:20 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,744

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
You cannot install an ".rpm" package with
Quote:
# ./jdk-1_5_015-linux-i586-rpm
*The command is # 'rpm -Uvh jdk-1_5_015-linux-i586-rpm'

And yes, the installer 'sh setupLinux.bin' will work with
"sun-java-5" , my version for the new test : "1.5.0_15"

It seems you also have "/usr/java/jdk1.6.0/"
Hide it, change the linking, or uninstal it....
it will not work with the greenstone files.

Rgds

Last edited by knudfl; 07-08-2008 at 09:27 AM.
 
Old 07-09-2008, 01:06 AM   #8
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by knudfl View Post

It seems you also have "/usr/java/jdk1.6.0/"
Hide it, change the linking, or uninstal it....
it will not work with the greenstone files.
well I have already installed the jdk.

#rpm -q jdk
jdk1.5.0_15-fcs


and don't have any jdk 1.6.0


thanks
shahz
 
Old 07-09-2008, 02:04 AM   #9
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
hi, knudfl

if you have installed greenstone within linux can you send me the step by step procedure then I may come to know that what I am missing, I really want to run it on Linux, for the time being I am running it on windows 2003 server but don't want to run it on windows.


thanks
shahz
 
Old 07-09-2008, 06:06 AM   #10
Vinod Vellore
LQ Newbie
 
Registered: Jul 2008
Location: Chennai, India
Posts: 6

Rep: Reputation: 0
RPM need to be installed by following command :
# rpm -ivh jdk-1_5_015-linux-i586-rpm
Check installed rpm by :
# rpm - qa | jdk
 
Old 07-09-2008, 11:08 AM   #11
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,744

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
# 10 Vinod_Vellore : I prefer 'rpm -Uvh .. ' ( U = upgrade etc. )
The 2' command => 'rpm -qa | grep jdk' (except with "java-1.5.0-sun")
........

There is really no step by step for greenstone, the installer
just installs everything to /opt/greenstone

The only condition to be met is having java 5 ( = 1.5 )

Please do command 'java -version' to check installation.

Rgds
 
Old 07-09-2008, 11:49 PM   #12
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by Vinod Vellore View Post
RPM need to be installed by following command :
# rpm -ivh jdk-1_5_015-linux-i586-rpm
Check installed rpm by :
# rpm - qa | jdk

Mr vinod vellor my problem was not installing an rpm anyhow the above commands I know for years thank you very much.
 
Old 07-10-2008, 03:30 AM   #13
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
I have installed the jdk properly now when I run the command java -version I get the following

java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Server VM (build 10.0-b23, mixed mode)

now when I run the greenstone installation wizard I get some error like the following.

This application requires a Java Run Time Environment (JRE)
to run. Searching for one on your computer was not successful.
Please use the command line switch -is:javahome to specify
a valid JRE. For more help use the option -is:help.


can some body help me on this thanks in advance. I think its have something with the jre path.

thnaks
shahz
 
Old 07-10-2008, 02:28 PM   #14
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,744

Rep: Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551Reputation: 2551
The installer will find the path itself. (usually)

But will not accept version 1.6

Version 1.5 will work.

Your own example : jdk-1_5_015-linux-i586-rpm will work.

So please change version. I tested both. See line "7" #7.

Rgds
 
Old 07-12-2008, 12:02 AM   #15
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Original Poster
Rep: Reputation: 29
Thanks knudfl

its finally works thank you very much, and it worked with 1.5, I have for now file permission problem did you have the same also because on my web server now its giving 500 Internal server error wich is I think file permission. any idea



thanks again
shahz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot repair jre-6u2-linux-i586-rpm install tjcarol Linux - Software 1 09-03-2007 06:50 PM
Where is jdk-1_5_0_10-linux-i586.bin for BLFS 6.2? rwcooper Linux From Scratch 1 08-03-2007 07:51 AM
chmod a+x jre-1_5_0-linux-i586-rpm.bin chemichael Fedora 4 09-24-2005 10:23 AM
Installing j2re-1_4_2_04-linux-i586.rpm paisano2k Fedora 12 05-07-2004 02:56 AM
j2re-1_4_1_01-linux-i586-rpm.bin gsikora Linux - Software 2 01-19-2003 09:55 PM


All times are GMT -5. The time now is 11:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration