LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 12-17-2007, 04:20 PM   #1
guages7
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Rep: Reputation: 0
Post How to use Red Hat Cluster Suite for Apache


I am trying to setup up a Apache (fail-over) cluster however I receive the following errors while try to start.

I have the Cluster suite installed on RHEL5.1 Server, I am using the GUI tool, system-config-cluster to start the tool to add my information in.

I have two servers, all I want this Cluster suite to do is pick up if the other service dies (apache) on one of them.

Does anyone have any suggestions on how to get this going, I have configure the GUI tool and I get errors (Unable to connect to cluster infrastructure). And when I start the GUI tool, I get (because node is not part of cluster, the management tab is not available).

Any help would be greatly appreciated.
 
Old 12-18-2007, 02:11 AM   #2
lncube
LQ Newbie
 
Registered: Dec 2007
Posts: 2

Rep: Reputation: 0
What error are you getting exactly? Copy and paste the output
 
Old 12-18-2007, 06:01 AM   #3
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
The /etc/cluster/cluster.conf would be of great help.
 
Old 12-18-2007, 08:40 AM   #4
guages7
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by elcody02 View Post
The /etc/cluster/cluster.conf would be of great help.
Let me get a copy of it out of the file.


Thanks
 
Old 12-18-2007, 09:07 AM   #5
guages7
LQ Newbie
 
Registered: Dec 2007
Posts: 4

Original Poster
Rep: Reputation: 0
[root@rh51test cluster]# cat cluster.conf
<?xml version="1.0" ?>
<cluster config_version="2" name="apache1">
<fence_daemon post_fail_delay="0" post_join_delay="3"/>
<clusternodes/>
<cman/>
<fencedevices/>
<rm>
<failoverdomains/>
<resources>
<script file="/etc/rc.d/init.d/httpd" name="Apache HTTP Server"/>
<fs device="/dev/hda6" force_fsck="0" force_unmount="0" fsid="6443" fstype="ext3" mountpoint="/var/www/html/" name="httpd-content" options="" self_fence="0"/>
<ip address="10.10.10.145" monitor_link="1"/>
</resources>
<service autostart="1" name="AP1">
<script ref="Apache HTTP Server"/>
<fs ref="httpd-content"/>
<ip ref="10.10.10.145"/>
</service>
</rm>
</cluster>
[root@rh51test cluster]#


This is my configuration on my first server, the second server has the ip address of 10.10.10.146 and I want it to be if the first server went down the second server would pick up. However when I set up the second server I get connection failed errors.
 
Old 12-18-2007, 06:41 PM   #6
rhbegin
Member
 
Registered: Oct 2003
Location: Arkansas, NWA
Distribution: Fedora/CentOS/SL6
Posts: 381

Rep: Reputation: 23
I figured it out, I configured the first server and scp'd the file to the second server.

I am able to unplug one of them now and it fails over, however I am having difficulty with the first server, got some kinks to work out. I totally redid my configuration and I got luci running so I can bring up https://servername:8084 in a browser and do configuration and restart services.

If anyone ever needs a hand on this let me know...
 
Old 12-19-2007, 04:49 AM   #7
elcody02
Member
 
Registered: Jun 2007
Posts: 52

Rep: Reputation: 17
I would say, as long as don't have any nodes defined (see clusternodes tag) you will have no success getting up the cluster. Also a failoverdomain is missing for the failover.

And last but not least don't forget to configure fencing. You are using a local filesystem and risc inconstencies when not having it.

And I also doubt that the filesystem is shared isn't it (/dev/hda is ide and therefore not shared).

Last edited by elcody02; 12-19-2007 at 04:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
red hat cluster suite and mysql stefano65 Linux - Enterprise 6 09-12-2010 10:45 AM
red hat cluster suite version 5 renegade7 Linux - Software 0 06-27-2007 09:17 AM
MySQL InnoDB Failover and Red Hat Cluster Suite stefano65 Red Hat 1 11-18-2006 01:35 PM
LXer: Nucleus Software Certifies FinnOne Suite Applications On Red Hat ... LXer Syndicated Linux News 0 09-01-2006 08:33 AM
Installation Oracle 9i Developer Suite on Red Hat Linux 7.3 akamol Linux - Software 3 03-01-2004 04:53 PM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration