LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Enterprise (http://www.linuxquestions.org/questions/linux-enterprise-47/)
-   -   How to update RHEL (http://www.linuxquestions.org/questions/linux-enterprise-47/how-to-update-rhel-570387/)

sonirajesh 07-18-2007 09:09 AM

How to update RHEL
 
Hi,

i am using RHEL 4.0 ES

i want to reinstall all software + kernal from distribution pack, because i think some of software get corrupted. like yum/up2date throwing library error.
so i want to reinstall them from pack.

what option to do same direct from CD.

Thanks

Lenard 07-19-2007 04:20 AM

Use rpm, please read: man rpm
Or from the online manuals available: http://www.redhat.com/docs/manuals/enterprise/

angryfirelord 07-24-2007 02:07 PM

Can you post the output of yum update?

sonirajesh 07-24-2007 11:30 PM

please find reply
 
When use "yum update"

Traceback (most recent call last):
File "/usr/bin/yum", line 22, in ?
import yummain
File "/usr/share/yum/yummain.py", line 31, in ?
import yumcomps
File "/usr/share/yum/yumcomps.py", line 4, in ?
import comps
File "/usr/share/yum/comps.py", line 5, in ?
import libxml2
File "/usr/lib/python2.3/site-packages/libxml2.py", line 1, in ?
import libxml2mod
ImportError: /usr/lib/python2.3/site-packages/libxml2mod.so: undefined symbol: xmlNewDocPI


when run up2date command
--------------------------------------------------------------------
Traceback (most recent call last):
File "/usr/sbin/up2date", line 33, in ?
from up2date_client import up2date
File "/usr/share/rhn/up2date_client/up2date.py", line 27, in ?
from up2date_client import depSolver
File "/usr/share/rhn/up2date_client/depSolver.py", line 11, in ?
import packageList
File "/usr/share/rhn/up2date_client/packageList.py", line 20, in ?
import up2dateComps
File "/usr/share/rhn/up2date_client/up2dateComps.py", line 9, in ?
from rhpl import comps
File "/usr/lib/python2.3/site-packages/rhpl/comps.py", line 5, in ?
import libxml2
File "/usr/lib/python2.3/site-packages/libxml2.py", line 1, in ?
import libxml2mod
ImportError: /usr/lib/python2.3/site-packages/libxml2mod.so: undefined symbol: xmlNewDocPI

Lenard 07-25-2007 06:20 AM

Which versions of yum, python-urlgrabber, python-elementtree, python-sqlite and sqlite are installed?? Which version of up2date is installed?

rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" 'python*' sqlite up2date yum | sort

Hopefully the ones from either Dag Wieers site( http://dag.wieers.com/rpm/packages/ ) or from the CentOS4 site as per;

http://wiki.centos.org/HowTos/Packag...ment/YumOnRHEL

sonirajesh 07-25-2007 11:17 PM

output of above command:
python-2.3.4-14.1.i386
python-elementtree-1.2.6-7.el4.rf.i386
python-urlgrabber-2.9.6-1.2.el4.rf.noarch
up2date-4.4.69-25.i386

Lenard 07-26-2007 12:51 PM

Follow the advice here to install/ use yum;

http://wiki.centos.org/HowTos/Packag...ment/YumOnRHEL

FYI: RHEL4 is not yum enabled and since you have an out of date version of up2date installed with newer versions of the other listed packages, this is the cause of the errors.


All times are GMT -5. The time now is 01:11 PM.