LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Closed Thread
 
Search this Thread
Old 01-09-2005, 09:06 PM   #1
louisb
Member
 
Registered: Aug 2003
Posts: 132

Rep: Reputation: 15
Failed dependencies with in RPM


I'm trying to upgrade my Red Hat Linux Enterprise Linux AS 3.0. I have 394 RPM packages to upgraded. Please see my RPM output as follows:

[root@localhost root]# rpm -Uv /usr/src/redhat/RPMS/i386/*.*
warning: package glibc = 2.3.2-95.30 was already added, replacing with glibc <= 2.3.2-95.31
warning: package glibc-common = 2.3.2-95.30 was already added, replacing with glibc-common <= 2.3.2-95.31
warning: package glibc-debug = 2.3.2-95.30 was already added, replacing with glibc-debug <= 2.3.2-95.31
warning: package glibc-debuginfo = 2.3.2-95.30 was already added, replacing with glibc-debuginfo <= 2.3.2-95.31
warning: package glibc-debuginfo-common = 2.3.2-95.30 was already added, replacing with glibc-debuginfo-common <= 2.3.2-95.31
warning: package glibc-devel = 2.3.2-95.30 was already added, replacing with glibc-devel <= 2.3.2-95.31
warning: package glibc-headers = 2.3.2-95.30 was already added, replacing with glibc-headers <= 2.3.2-95.31
warning: package glibc-profile = 2.3.2-95.30 was already added, replacing with glibc-profile <= 2.3.2-95.31
warning: package glibc-utils = 2.3.2-95.30 was already added, replacing with glibc-utils <= 2.3.2-95.31
warning: package nscd = 2.3.2-95.30 was already added, replacing with nscd <= 2.3.2-95.31
warning: package procps = 2.0.17-10 was already added, replacing with procps <= 2.0.17-13
warning: package procps-debuginfo = 2.0.17-10 was already added, replacing with procps-debuginfo <= 2.0.17-13
error: Failed dependencies:
glibc-devel = 2.3.2-95.3 is needed by (installed) nptl-devel-2.3.2-95.3

I'm not worried about the warning messages however, I 'm hainv problems with the Failed dependency.

I've peformed queries on the above to determine there status as follows:

[root@localhost root]# rpm -q nptl-devel-2.3.2-95.3
nptl-devel-2.3.2-95.3
[root@localhost root]# rpm -q glibc-devel-2.3.2-95.3
glibc-devel-2.3.2-95.3

Can anyone tell me what's wrong here?

Thanks
 
Old 01-10-2005, 09:42 AM   #2
Capt_Caveman
Senior Member
 
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 57
Please do not post the same question more than once. If you feel that your original question hasn't been answered then you may bump your thread after 24, otherwise please try and be patient.

http://www.linuxquestions.org/rules.php

Direct any replies to the original thread:
http://www.linuxquestions.org/questi...hreadid=275886
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RPM Failed dependencies louisb Linux - Enterprise 3 01-27-2005 01:58 PM
Failed dependencies in RPM louisb Linux - Enterprise 1 01-12-2005 02:37 AM
rpm - failed dependencies jonnycarlos Linux - Software 3 04-15-2004 10:57 AM
rpm failed dependencies wedgeworth Linux - Software 4 12-30-2003 03:55 PM
RPM 'failed dependencies': Why can I not install any rpm packages? leontini Linux - Newbie 7 09-16-2003 12:44 AM


All times are GMT -5. The time now is 05:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration