LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
LinkBack Search this Thread
Old 08-09-2006, 03:28 AM   #1
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Rep: Reputation: 15
Question dhcp - PXE booting


Hi.

I have a server witch i setup for Linux installations. You dont always have cd-roms or dvd-roms available.
I have dhcp configured:

ddns-update-style interim;
ignore client-updates;

subnet 10.10.10.0 netmask 255.255.255.0 {

# --- default gateway
option routers 10.10.10.253;
option subnet-mask 255.255.255.0;

option domain-name "install";
option domain-name-servers 10.10.10.160;

option time-offset -18000; # Eastern Standard Time

range dynamic-bootp 10.10.10.50 10.10.10.60;
option broadcast-address 10.10.10.255;
default-lease-time 21600;
max-lease-time 43200;

allow booting;
allow bootp;
class "pxeclients" {
match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
next-server 10.10.10.161;
filename "linux-install/pxelinux.0";
}

When i try to boot via pxe with my notebook, it doesnt always boot via pxe. Every one out of 100 it boots in.
I have tryed the option of:
host laptop {
next-server 10.10.10.161;
hardware ethernet 00:00:05:1HL:0B;
fixed-address 10.10.10.100;
filename "linux-install/pxelinux.0";
}
but still wount boot proparly. This is what my notebook gives me:
Intel UNDI, PXE-2.0 (build 082)
Copyright (C) 1997-2000 Intel Corporation
For Realtek RTL8139(X)/8130/810X PCI Fast Ethernet Controller v.2.13 (020326)

CLIENT MAC ADDR: 00:00:05:1HL:0B GUID 00000000-0000-0000-0000-000000000000

PXE-E51: No DHCP or proxyDHCP offers were received.
PXE-M0F: Exiting PXE ROM.

Could someone please tell me what i'm doing wrong.When you look at /var/lib/dhcp/dhcpd.leases you see a lot of other machines that have taken an ip. Is there an way how you could block/stop sertian mac address or pc's from taking ip's.

Thanks
 
Old 08-09-2006, 03:50 AM   #2
slantoflight
Member
 
Registered: Aug 2005
Distribution: Smoothwall
Posts: 283
Blog Entries: 3

Rep: Reputation: 35
Smile

Try commenting out
ignore client-updates;

and

class "pxeclients" {
match if substring(option vendor-class-identifier, 0, 9) = "PXEClient";
next-server 10.10.10.161;
filename "linux-install/pxelinux.0";
}

If you actually don't care about who is able to pxe boot on your network or temporarily you could simplify things.

Code:
ddns-update-style interim;

subnet 10.10.10.0 netmask 255.255.255.0 {

# --- default gateway
option routers 10.10.10.253;
option subnet-mask 255.255.255.0;

option domain-name "install";
option domain-name-servers 10.10.10.160;

option time-offset -18000; # Eastern Standard Time

range dynamic-bootp 10.10.10.50 10.10.10.60;
option broadcast-address 10.10.10.255;
default-lease-time 21600;
max-lease-time 43200;

allow booting;
allow bootp;
filename "linux-install/pxelinux.0";
}
Oh one more minor thing. Could'nt help but notice that you're missing a bracket.

You have the ending class bracket, but not the ending subnet bracket. On the other dhcp.conf does have a weird syntax. Maybe it wont care. It might interest you to put a bracket here though.

Code:
filename "linux-install/pxelinux.0";
}
}
 
Old 08-09-2006, 06:33 AM   #3
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Original Poster
Rep: Reputation: 15
Hi.

Tryed that. I'm affraid no luck. It still doesnt want to boot.

Is there something else i can try?

Thanks
 
Old 08-09-2006, 09:49 PM   #4
slantoflight
Member
 
Registered: Aug 2005
Distribution: Smoothwall
Posts: 283
Blog Entries: 3

Rep: Reputation: 35
Quote:
Originally Posted by icedude
Hi.

Tryed that. I'm affraid no luck. It still doesnt want to boot.

Is there something else i can try?

Thanks
There are no obvious answers left, I'm afraid. Maybe physical damage to the nics.

One out of every hundred boots doesn't seem like logical results. How can booting of the same config on the same configuration give different reactions?

You have to become a scientist now. Does dhcp work at all? Have you tried it on different computers? Have you tried different ethernet cable?
 
Old 08-10-2006, 03:29 AM   #5
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Original Poster
Rep: Reputation: 15
Yes i have tryed different machines. They boot.
The notebook is fairly new. Is'nt there any other options to specify in dhcpd.conf for pxe boot?
 
Old 08-10-2006, 02:42 PM   #6
slantoflight
Member
 
Registered: Aug 2005
Distribution: Smoothwall
Posts: 283
Blog Entries: 3

Rep: Reputation: 35
Quote:
Originally Posted by icedude
Yes i have tryed different machines. They boot.
I'd hazard a guess thats its your notebook then and no option in dhcp will help you.
 
Old 09-22-2010, 08:42 AM   #7
parag123456
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Hi,
I am having the same problem.
DHCP on fedora 13 box ,
tried so many options ,helps from net but no luck .
gets success 1-2 times from 10 attempts.
Client machines are different models from HP & IBM with updated all BIOS.

If I started client PCs in windows or linux os then it surely gets ip address from dhcp .

Also they all are on same subnet . also tried back-to-back( cross) cable to client & server but still the results are same.

If anyone has addressed this problem , please update.

Thanks,
 
Old 09-23-2010, 06:57 AM   #8
icedude
Member
 
Registered: Nov 2004
Location: South Africa
Posts: 43

Original Poster
Rep: Reputation: 15
Hi.

I managed to get it to work. I did some googling and found some ideas.
Try this: ( please edit ip info for your needs)


authoritative;
ddns-update-style interim;
ignore client-updates;
allow booting;
get-lease-hostnames true;

class "pxe" {
match if substring (option vendor-class-identifier, 0, 9) = "PXEClient";
}

class "etherboot" {
match if substring (option vendor-class-identifier, 0, 9) = "Etherboot";
}


subnet 10.10.10.0 netmask 255.255.255.0 {

# --- default gateway
option routers 10.10.10.253;
option subnet-mask 255.255.255.0;
option broadcast-address 10.10.10.255;

option domain-name "domain";
option domain-name-servers 10.10.10.4, 10.10.10.160;

option time-offset -18000; # Eastern Standard Time
# option ntp-servers 10.10.10.4;
# option netbios-name-servers 10.10.10.251;
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
# option netbios-node-type 2;

pool {
range dynamic-bootp 10.10.10.50 10.10.10.60;
default-lease-time 21600;
max-lease-time 43200;
server-name "server-name";
next-server 10.10.10.161;
filename "/linux-install/pxelinux.0";
allow members of "pxe";
allow members of "etherboot";
}

}


Please let me know if it works. This will allow dhcp to allow "pxe clients" to get ip's and not for every dhcp requests.

This is the config that i currently use on my installation server.
 
Old 09-23-2010, 08:10 AM   #9
king-redhat-linux
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Thank you I have benefited from this information very
 
Old 09-24-2010, 04:50 AM   #10
parag123456
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Hi icedude,

Thanks for your reply ,I gonna try this & update you soon.
 
Old 09-28-2010, 05:36 AM   #11
parag123456
LQ Newbie
 
Registered: Sep 2010
Posts: 3

Rep: Reputation: 0
Hi icedude,

It worked like a charm.Many thanks for your help.

Bye..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pxe booting geden Linux - Networking 5 09-08-2006 07:26 PM
PXE Booting pvlajith Red Hat 1 06-06-2006 08:15 PM
PXE/Network Booting OS ap0ll0 Linux - Networking 1 03-23-2006 02:11 PM
Network Install using PXe, DHCP, TFTP and FTP Aseem Suse/Novell 1 12-15-2005 10:57 PM
DHCP vs PXE woes :S kevingpo Linux - Networking 2 11-05-2005 01:02 PM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration