LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 11-18-2005, 06:37 AM   #1
HelaWann
LQ Newbie
 
Registered: Nov 2005
Posts: 6

Rep: Reputation: 0
Crash while resyncing /dev/md0


Hi folks.

I am running a heartbeat vluster on two rhel3 mashines. It ist an FTP-Server, which uses a san-device an data-partition. This san-Device is on two EMC mashines, so i mirror the one partition (from one EMC) onto the other using software raid level 1.

Now, one cluster node crashed and the other made a takeover, as it should be. the mirror was out of sync, so it startet a resync on /dev/md0. This is very fine.

Now, both nodes "like" to crash while resyncing /dev/md0. I am trying it for 6 hours now, but on every try the one performing the resync crashes someweher in this action. Heartbeat notices the crash and the other node makes a takeover, initiating another resync, because it was not finished. So, this node crashes again while resyncing, waht makes the first node, i rebooted it in the meantime, to make another takeover. I notices too thet the mirror ist out of sync and everything begins again from the start.

Has anybody similar problems using rhel3 with 2.4.21-32.ELsmp, heartbeat 1.2.3?

Thanks a lot for help.

Hela Wann
 
Old 12-06-2005, 08:52 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Anytime I had one mirror keep crashing during a resync, it usually indicated bad blocks, bad or failing hard disk.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RAID5 using mdadm, how to mount /dev/md0? ggduff Linux - Software 4 11-14-2007 01:59 AM
PLEASE HELP: fsck.reiserfs --rebuild-sb /dev/md0 fails ofdofd Linux - General 2 10-26-2005 02:18 PM
can not mount RAID 0 /dev/md0 dysenteryduke Linux - Software 3 09-15-2005 03:19 PM
RAID 1 ... everyime I reboot, /dev/md0 is broken... rrohde Red Hat 1 10-26-2004 02:03 PM
Raid Weirdness -- /dev/md0: Invalid argument spiritwing Linux - Software 3 04-02-2004 09:52 PM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration