LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 11-06-2004, 01:25 PM   #1
STIBAL
LQ Newbie
 
Registered: Nov 2004
Posts: 8

Rep: Reputation: 0
cluster suite, I can visualize the two servers, quorum problem


I have the following problem, in this case we cant see the nodes active at the same time:

Clustat second node:
Cluster Status - cluster 10:26:58
Incarnation #1
(This member is not part of the cluster quorum)

Member Status
------------------ ----------
172.16.0.49 Active <-- You are here
172.16.0.48 Inactive

No Quorum - Service States Unknown

clustat first node
Cluster Status - cluster 10:26:42
Cluster Quorum Incarnation #1
Shared State: Shared Raw Device Driver v1.2

Member Status
------------------ ----------
172.16.0.49 Inactive
172.16.0.48 Active <-- You are here

Service Status Owner (Last) Last Transition Chk Restarts
-------------- -------- ---------------- --------------- --- --------

second node:
[root]# service clumanager status
Se está ejecutando clumembd (pid 2673)...
Se está ejecutando cluquorumd (pid 2671)...
Se está ejecutando clulockd (pid 2678)...
clusvcmgrd está parado
Note: Service manager is not running because this member
is not participating in the cluster quorum.

first node
[root]# service clumanager status
Se está ejecutando clumembd (pid 5547)...
Se está ejecutando cluquorumd (pid 5545)...
Se está ejecutando clulockd (pid 5552)...
Se está ejecutando clusvcmgrd (pid 5577)...

However if a run:

#/sbin/shutil -p /cluster/header

I view the same information in the both nodes

Thanks for your advice
 
Old 11-15-2004, 12:52 PM   #2
goestin
Member
 
Registered: Nov 2004
Location: Netherlands (east)
Distribution: debian, suse, novell linux desktop
Posts: 81

Rep: Reputation: 15
which software you are using for clustering and which linux distribution? i can't asure you i can help but i've been messing around with linux clusters a few weeks ago.

-cheers-
 
Old 12-09-2005, 07:06 AM   #3
Livio
LQ Newbie
 
Registered: Dec 2005
Location: Brazil
Posts: 4

Rep: Reputation: 0
In a cluster with 2 members, check that you are using Network Tiebreaker. The Disk Tiebreaker is not recommended in this case.
After that, check that your multicast or broadcast heartbeating is working well (try to ping multicast addresss. The detaulf is 255.0.0.11.)
If the cluster is undertanding that ther is still one member off, you need to give a aditional point to activate quorum:
cluforce 172.16.0.49
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat Cluster Suite - No Quorum vamosb Linux - Enterprise 9 12-09-2005 07:16 AM
redhat cluster suite matter comdaze Linux - Software 1 10-20-2005 03:18 AM
redhat cluster suite matter comdaze Linux - Enterprise 0 10-19-2005 11:10 PM
redhat cluster suite + samba openldap christopherccv Linux - Software 0 09-27-2005 08:16 AM
Router/Cluster with Two Servers Question 6tr6tr General 1 01-16-2004 05:53 PM


All times are GMT -5. The time now is 12:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration