LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 11-29-2009, 08:10 PM   #1
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Rep: Reputation: 30
5.4 - scientific linux enabling desktop effects does not work


Hi,

I am trying to enable the desktop effects on Scientific Linux 5.4, but
it does not work on my ThinkPad laptop. I'm thinking about installing
some proprietary ATI driver on the machine.

Does anyone know where I can get it? I tried the ATI's website but couldn't
find one for my graphics card (RADEON Mobile M6).

Perhaps, the Scientific Linux's Contrib repository may have some available.

Thanks.
 
Old 11-30-2009, 08:23 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
The open source drivers should work just fine. I'm not familiar with Scientif Linux, but every distribution I know of ships with the open source drivers by default, usually enabled, as well. Can you attach your /var/log/Xorg.0.log to a post here?

Adam
 
Old 12-03-2009, 09:39 PM   #3
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi,

Here is the output of /var/log/xorg.0.log:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-128.7.1.el5 i686 Red Hat, Inc.
Current Operating System: Linux slinux 2.6.18-164.6.1.el5 #1 SMP Tue Nov 3 23:11:58 EST 2009 i686
Build Date: 07 September 2009
Build ID: xorg-x11-server 1.1.1-48.67.el5
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 3 15:15:29 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Multihead layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Screen "Screen1" (1)
(**) | |-->Monitor "Monitor1"
(**) | |-->Device "Videocard1"
(**) |-->Input Device "Keyboard0"
(==) |-->Input Device "<default pointer>"
(==) The core pointer device wasn't specified explicitly in the layout.
Using the default mouse configuration.
(==) No FontPath specified. Using compiled-in default.
(==) FontPath set to:
unix/:7100,
built-ins
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Option "Xinerama" "off"
(==) Max clients allowed: 512, resource mask: 0xfffff
(II) Open ACPI successful (/var/run/acpid.socket)
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 1.0
X.Org XInput driver : 0.6
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/xorg/modules/fonts/libbitmap.so
(II) Module bitmap: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules/libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.0.0
ABI class: X.Org Video Driver, version 1.0
(++) using VT number 7
(II) ATI: ATI driver (version 6.6.3) for chipsets: ati, ativga
(II) RADEON: Driver for ATI Radeon chipsets: ATI Radeon QD (AGP),
(II) Loading sub module "radeon"
(II) LoadModule: "radeon"
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(II) Loading sub module "radeon"
(II) LoadModule: "radeon"
(II) Reloading /usr/lib/xorg/modules/drivers/radeon_drv.so
(**) RADEON(0): RADEONSaveScreen(2)
(WW) Not including screen "Screen0" in origins calculation.
 
Old 12-04-2009, 07:25 AM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Are you sure that's the full log file? Are you using two screens?
 
Old 12-05-2009, 01:37 AM   #5
pcandpc
Member
 
Registered: Apr 2005
Posts: 241

Original Poster
Rep: Reputation: 30
Hi,

As the log file is overwhelmingly large for this posting, I tried to shorten it.
If you can tell me what section in the file you're looking for, I can paste it again.

I'm not actually using two monitors. I chose that setting to make my screen resolution
work at 1024x768 for the laptop. For some reason, without this weird setting, the resolution
always defaults to 600x400 poorly.

Thanks.
 
Old 12-05-2009, 07:36 AM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
I would really need to see th whole thing. You can use a service like http://pastebin.com/ . One thing I did notice is that your X server was released 3.5 years ago. In the world of open source video drivers, that's nearly an eternity.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling Advanced Desktop Effects in Ubuntu PCWizKid Linux - Desktop 1 06-04-2008 07:34 AM
fedora 8 desktop effects.. enabling? Springs Linux - Newbie 3 05-13-2008 08:02 AM
Problem in enabling desktop effects on fedora 8. yaswanthg Linux - Newbie 2 02-29-2008 06:51 AM
Enabling Desktop Effects Resets my Session wera662001 Linux - Laptop and Netbook 1 02-19-2007 05:31 PM


All times are GMT -5. The time now is 06:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration