LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 03-25-2010, 01:04 PM   #1
sunr2007
Member
 
Registered: Jan 2009
Location: Bangalore , India
Distribution: Fedora 12
Posts: 65

Rep: Reputation: 17
unable to login to buildroot


Hi all,
i built a jffs2 filesystem by using make at91sam9261ek_config for buildroot.2010.02 . everything went fine
but im unable to login on to my target board

when i type root and press enter
it is redirecting me back to the login

and when i press any other name , it asks for password but again come back to login when i press enter



"Welcome to Buildroot

buildroot login: root


Welcome to Buildroot

buildroot login: ravi
Password:


Welcome to Buildroot

buildroot login: "


below is my /etc/inittab file any idea what might be wrong?

# /etc/inittab
#
# Copyright (C) 2001 Erik Andersen <andersen@codepoet.org>
#
# Note: BusyBox init doesn't support runlevels. The runlevels field is
# completely ignored by BusyBox init. If you want runlevels, use
# sysvinit.
#
# Format for each entry: <id>:<runlevels>:<action>:<process>
#
# id == tty to run on, or empty for /dev/console
# runlevels == ignored
# action == one of sysinit, respawn, askfirst, wait, and once
# process == program to run

# Startup the system
null::sysinit:/bin/mount -o remount,rw /
null::sysinit:/bin/mount -t proc proc /proc
null::sysinit:/bin/mount -a
null::sysinit:/bin/hostname -F /etc/hostname
null::sysinit:/sbin/ifconfig lo 127.0.0.1 up
null::sysinit:/sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
# now run any rc scripts
::sysinit:/etc/init.d/rcS

# Set up a couple of getty's
#tty1::respawn:/sbin/getty 38400 tty1
#tty2::respawn:/sbin/getty 38400 tty2

# Put a getty on the serial port
ttyS0::respawn:/sbin/getty -L ttyS0 115200 vt100


# Logging junk
null::sysinit:/bin/touch /var/log/messages
null::respawn:/sbin/syslogd -n -m 0
null::respawn:/sbin/klogd -n
tty3::respawn:/usr/bin/tail -f /var/log/messages

# Stuff to do for the 3-finger salute
::ctrlaltdel:/sbin/reboot

# Stuff to do before rebooting
null::shutdown:/usr/bin/killall klogd
null::shutdown:/usr/bin/killall syslogd
null::shutdown:/bin/umount -a -r
null::shutdown:/sbin/swapoff -a

any idea what is wrong ? how to debug this ?thanks
warm regards,
Ravi Kulkarni.
 
Old 04-19-2010, 03:07 PM   #2
Karl Godt
Member
 
Registered: Mar 2010
Location: Kiel , Germany
Distribution: once:SuSE6.2,Debian3.1, aurox9.2+3,Mandrake?,DSL? then:W7st,WVHB, #!8.10.02,PUPPY4.3.1 now:Macpup
Posts: 308

Rep: Reputation: 45
Try
mchne@ravi..>su
..> sudo
..> passwd
..> passwd root
..> passwd ravi
..> su passwd
..> sudo passwd
..> su passwd root
..> su passwd ravi
..> sudo passwd root
..> sudo passwd ravi

At DSL I had this outcome:
m@kg.>passwdENTER
>passwd: This applet requires root privileges !
m@kg.>su
>Password:ENTER
>su: Authentification failure
>Sorry.
m@kg.>sudo passwd
>Changing password for root
>Enter the new password (minimum of 5, maximum of 8 characters)
>Please use a combination of upper and lower case letters and numbers.
m@kg.>Enter new password:DsL24
>Bad password: too short.
m@kg.>Re-enter new password:DsL24
>Password changed
m@kg.>

AND FOR THE LOGINSCREEN : ADMIN and ROOT -Login has to be enabled and minimum login-ID set from mostly default USERS 1000 down to ROOT 0 at USERS/GROUPS -point in the SystemsSettings-Menu !

dsl can not copy'paste from xterm so I did wrote down to a piece of paper and typed in per hand
 
Old 04-27-2010, 04:53 PM   #3
FemtoLinux
LQ Newbie
 
Registered: Apr 2010
Posts: 11

Rep: Reputation: 0
Show us your /etc/passwd.

There is a good chance that root shell is wrong, so the system does let you in, tries to run the shell, it crashes or something and you get back to the login prompt.
 
Old 04-28-2010, 01:04 AM   #4
sunr2007
Member
 
Registered: Jan 2009
Location: Bangalore , India
Distribution: Fedora 12
Posts: 65

Original Poster
Rep: Reputation: 17
Thanks for your reply . But the problem was in kernel . i had miss config related to console n all. It was not due to /etc/passwd as i suspected initially.
warm regards,
Ravi Kulkarni.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to login as user; can login as root. rksanders Debian 24 02-09-2011 08:01 AM
Buildroot www_linux Linux - Newbie 4 01-21-2009 10:33 PM
unable to graphic login, but text login is OK! cqmyg5 Slackware 2 01-16-2007 09:05 PM
unable to login because no login prompt DX2 Linux - General 1 05-25-2005 12:33 PM
unable to login due to login expiry niiha Programming 2 09-02-2004 10:50 AM


All times are GMT -5. The time now is 11:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration