LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 03-31-2010, 03:42 AM   #1
bkrpri
LQ Newbie
 
Registered: Mar 2010
Posts: 1

Rep: Reputation: 0
Unable to auto detect SD card connected to USB2640 hub controller


Hi,

I am working on a custom board which has TI Davinci Processor running Linux 2.6.10 as the host processor to which we have a USB2640 hub controller connected on the USB bus. This hub controller has a built in SD card controller. So basically this hub supports two USB devices and one SD card.
The problem I am facing right now is that if the SD card is connected during kernel boot up, the SD card gets detected and also enumerated. After this I am able to mount the SD card.
But in case I plug in the SD card after kernel boot up, the SD card does not get detected.
The USB devices conected to the USB ports are detected when they are hot plugged.

So how do I enable hot plugging for the SD card?

Thanks,
bkrpri
 
Old 04-02-2010, 10:37 AM   #2
tiekookeit
LQ Newbie
 
Registered: Jan 2009
Location: Brazil
Distribution: debian
Posts: 16

Rep: Reputation: 1
Ok, try this.
1 - Boot your linux box with a SD card connected.
2 - execute lsmod all modules loaded in the sistem will be displayed, try to find out the name of the module that your card is using, supose usb-storage
3 - re-boot again without the SD and try to load the module manually, the one you think you found in the previous step, using: modprobe module_name
I hope it works, and if does, you may put the command in /etc/rc.local, so then the module loads on boot time.

Last edited by tiekookeit; 04-02-2010 at 10:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to detect SATA controller when installing RHEL 4/5/5.1 basharath2 Linux - Hardware 2 08-21-2008 04:07 PM
Can Ubuntu 7.04 detect HD connected to ATA66 Controller satimis Ubuntu 4 06-25-2007 12:07 PM
RH doesn't detect my Serial modem connected to a PCI Serial card ricky_ds Linux - Hardware 1 08-17-2006 02:37 PM
how to auto detect when connected to internet? rohan208 Programming 2 07-24-2004 04:00 PM
Mounting Drives connected to a controller card tvman Linux - Newbie 2 05-08-2002 06:18 PM


All times are GMT -5. The time now is 09:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration