LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 02-27-2008, 10:16 AM   #1
BrandonChristel
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
TS-linux ssh drops connection as soon as login is successful


Hello all-
I am trying to ssh into an embedded computer running ts-linux (debian based), if you guys are familiar. i got ssh installed and ran the keymakers. whenever i try to log in, it doesn't want to stay connected - it logs in and then exits immediately.

i ran ssh in -v and here's the output. looks like it connects and then exits out. any ideas?


brandons-mbp:Sites brandonchristel$ ssh glider@192.168.1.133
Password:
Connection to 192.168.1.133 closed by remote host.
Connection to 192.168.1.133 closed.


brandons-mbp:Sites brandonchristel$ ssh -v glider@192.168.1.133
OpenSSH_4.5p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to 192.168.1.133 [192.168.1.133] port 22.
debug1: Connection established.
debug1: identity file /Users/brandonchristel/.ssh/identity type -1
debug1: identity file /Users/brandonchristel/.ssh/id_rsa type -1
debug1: identity file /Users/brandonchristel/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3p2 Debian-9
debug1: match: OpenSSH_4.3p2 Debian-9 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '192.168.1.133' is known and matches the RSA host key.
debug1: Found key in /Users/brandonchristel/.ssh/known_hosts:5
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/brandonchristel/.ssh/identity
debug1: Trying private key: /Users/brandonchristel/.ssh/id_rsa
debug1: Trying private key: /Users/brandonchristel/.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive
Password:
debug1: Authentication succeeded (keyboard-interactive).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: channel 0: free: client-session, nchannels 1
Connection to 192.168.1.133 closed by remote host.
Connection to 192.168.1.133 closed.
debug1: Transferred: stdin 0, stdout 0, stderr 89 bytes in 0.0 seconds
debug1: Bytes per second: stdin 0.0, stdout 0.0, stderr 3135.8
debug1: Exit status -1

as a note: for the passphrase in the keygen i didn't input anything. when i logged in, i used the normal user password. Is that the correct way to go about it? It looks like it accepts the connection before it gets cranky and drops it.

Thanks for the help!
brandon
 
Old 02-27-2008, 10:29 AM   #2
BrandonChristel
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Original Poster
Rep: Reputation: 0
I double posted in linux-software, a cardinal sin, i know, but i need an answer quick. i'll delete one as soon as one gets going.

from the other thread
- i looked for ~/.ssh/known_hosts, it doesn't exist on the remote computer and i emptied it on the computer i'm ssh-ing from - same error after accepting key.

Last edited by BrandonChristel; 02-27-2008 at 11:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection drops with SUSE linux 10 + linksys router vprv10 Linux - Networking 7 08-15-2006 12:39 AM
SSH closes connection before login goose240 Linux - Networking 4 02-14-2005 04:14 AM
ssh server is closing the connection just after successful login puru_09 Linux - Security 3 04-03-2004 12:42 AM
why ssh server is closing the connection just after successful login puru_09 Linux - Networking 0 03-30-2004 12:25 AM
ssh connection drops jeffpoulsen Linux - Networking 5 10-08-2003 09:57 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration