LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 04-21-2011, 04:19 AM   #1
pooja.panda87
LQ Newbie
 
Registered: Apr 2011
Posts: 2

Rep: Reputation: 0
Question ts can not found


I am trying to cross-compile for embedded arm using the openembedded generated toolchain and rootfs

well on my PC I have my target directory containing libts and so on.

configure QT :
./configure -prefix usr/arm/qt_embedded -hostprefix usr/arm/qt_embedded -xplatform qws/linux-arm-g++ -embedded arm -little-endian -host-little-endian -qt-freetype -depths 16 -plugin-decoration-default -qt-gfx-linuxfb -plugin-gfx-linuxfb -qt-kbd-yopy -plugin-kbd-yopy -qt-mouse-tslib -plugin-mouse-tslib -release -opensource -shared -no-fast -no-largefile -exceptions -accessibility -stl -qt3support -xmlpatterns -phonon -phonon-backend -svg -webkit -scripttools -no-mmx -no-3dnow -no-sse -no-sse2 -qt-zlib -qt-gif -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -openssl -continue -v -silent -no-optimized-qmake -nis -no-cups -iconv -pch -reduce-relocations -no-separate-debug-info

it generates the Makefile but when i run qmake it show the error as :
"../arm-none-linux-gnueabi/bin/ld: cannot find -lts
collect2: ld returned 1 exit status"
make[1]: *** [../../lib/libQtGui.so.4.5.3] Error 1
make[1]: Leaving directory `/home/vinod/omap3530/qt-embedded-linux-opensource-src-4.5.3/src/gui'
make: *** [sub-gui-make_default-ordered] Error 2


where am i getting wrong, plz guide me.
thanks.

Last edited by pooja.panda87; 04-21-2011 at 04:25 AM. Reason: some spelling mistakes
 
Old 04-21-2011, 05:33 AM   #2
cnxsoft
Member
 
Registered: Nov 2010
Location: Thailand
Distribution: Fedora 12, Ubuntu 10.10
Posts: 166

Rep: Reputation: 29
You may have to cross compile libts by yourself.

Others seem to have had the same problems as you did:
http://www.qtforum.org/article/33318...0-problem.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Directory not found; -xzvf not found; Makefile not found RealGomer Linux - Software 4 09-20-2010 10:02 AM
Fedora Core 6 boot No medium found No volume groups found awadhut Linux - Hardware 1 02-22-2007 01:15 AM
INIT NOT FOUND + HDA(x) NOT FOUND fred99 Linux - Software 1 02-25-2005 02:10 PM
gcc vs. g++ -> iostream lib found vs. not found CooManChu Linux - General 1 12-11-2004 09:20 AM
PDC 20276 - Promise Fasttrack 133 found but still not found.. FransE Linux - Hardware 3 02-16-2004 07:44 AM


All times are GMT -5. The time now is 08:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration