LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices



Reply
 
Search this Thread
Old 11-09-2009, 11:50 AM   #1
vhn
LQ Newbie
 
Registered: Nov 2009
Posts: 6

Rep: Reputation: 0
Sometimes "shutdown" command takes a lot of time


Hi All,
I'm using PowerPC 82xx microprocessor with Linux 2.6.10 running on it. I observe that sometimes when "shutdown -r 0" command is executed, system does not reboot the board. But by executing "ps axjf" command, I notice that the process status for "shutdown" is "D", which means it has entered uninterruptible sleep state.
Any suggestions?
 
Old 11-15-2009, 01:01 PM   #2
diilbert
Member
 
Registered: Nov 2003
Location: North of the Border
Distribution: Gentoo & Debian
Posts: 155

Rep: Reputation: 30
Did you try using just reboot?
 
Old 11-17-2009, 11:20 PM   #3
vhn
LQ Newbie
 
Registered: Nov 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Yes. A similar behaviour is seen while "reboot" command is executed. Sometimes the reboot process enters the uninterruptible sleep state and the board does not reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I disable "shutdown" and "restart" options in KDE logout screen for all users? maxgsp Linux - Distributions 1 12-12-2008 04:18 PM
Takes a lot of time to get a prompt bengoavs Linux - Software 2 01-02-2008 11:14 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 11:18 PM
Lost "Shutdown" and "Restart" From system menu in FC6 Nader1 Linux - Software 3 02-12-2007 05:40 PM
How can I make the "shutdown" command available for all users? LinuxSeeker Linux - General 7 06-01-2005 06:40 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration