LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 02-03-2008, 03:23 AM   #1
shearer
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
Installing xfree86 on Technologic Ts-7300(Of architecture ARM) ) board


Hi

I , along with a friend of mine, am trying to install X-Window System on TS7300
ARM9 board . We have managed to configure internet and
run text based browser eg lynx or www-browser. We installed:


# apt-get update

# apt-get install icewm

# apt-get install xserver-xfree86

# apt-get install x-window-system-core

# apt-get install xdm

# apt-get install numlockx

# apt-get install xterm

(but not in this order ..)

But we have not been able to get it to run. XDM fails
whenever we try and run startx after 5 attempts.

The error returned is:
(II) VGA: Generic VGA driver (version 4.0) for
chipsets: generic
(EE) No devices detected.

Fatal server error:
no screens found

The log file and Config file has been included in the end of the
post..

Please suggest a possible remedy.

Thanks in anticipation

Regards
Jaspreet

The logfile:
Code:
$ cat XFree86.0.log
XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-14sarge5
20071006101817 root@)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.18-5-iop32x armv5tel
[ELF]
Build Date: 06 October 2007

This version of XFree86 has been extensively modified
by the Debian
Project, and is not supported by the XFree86 Project,
Inc., in any
way. Bugs should be reported to the Debian Bug
Tracking System; see
<URL: http://www.debian.org/Bugs/Reporting >.

We strongly encourage the use of the "reportbug"
package and command
to ensure that bug reports contain as much useful
information as
possible.

Before filing a bug report, you may want to consult
the Debian X FAQ:
XHTML version:
file:///usr/share/doc/xfree86-common/FAQ.xhtml
plain text version:
file:///usr/share/doc/xfree86-common/FAQ.gz

Module Loader present
OS Kernel: Linux version 2.4.26-ts11 (root@construct)
(gcc version 3.3.4) #35 Thu Jul 6 15:44:29 MST 2006
Markers: (--) probed, (**) from config file, (==)
default setting,
(++) from command line, (!!) notice, (II)
informational,
(WW) warning, (EE) error, (NI) not
implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Thu Jan
1 00:11:34 1970
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/lib/X11/fonts/CID" does not
exist.
Entry deleted from font path.
(**) FontPath set to
"unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/cyrillic,/usr/lib/X11/fon\
ts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,\
/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 2

(WW) Open APM failed (/dev/apm_bios) (No such file or
directory)
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x00000000 - 0x00000000 (0x1) MX[B]
[2] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[3] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) OS-reported resource ranges after removing
overlaps with PCI:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x00000000 - 0x00000000 (0x1) MX[B]
[2] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[3] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1 0 0x00000000 - 0x00000000 (0x1) MX[B]
[2] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[3] -1 0 0x00000000 - 0x00000000 (0x1) IX[B]
(II) LoadModule: "bitmap"
(II) Reloading
/usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading
/usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading
/usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading
/usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading
/usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading
/usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping
"/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o":
No symbols found
Skipping
"/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o":
No symbols found
Skipping
"/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o":
No symbols found
Skipping
"/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o":
No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "vga"
(II) Loading /usr/X11R6/lib/modules/drivers/vga_drv.o
(II) Module vga: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 4.0.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) VGA: Generic VGA driver (version 4.0) for
chipsets: generic
(EE) No devices detected.

Fatal server error:
no screens found

When reporting a problem related to a server crash,
please send
the full server output, not just the last messages.
This can be found in the log file
"/var/log/XFree86.0.log".
Please report problems to submit@....
Xf86Config-4 File

Code:
$ cat XF86Config-4 
# XF86Config-4 (XFree86 X Window System server
configuration file)
#
# This file was generated by dexconf, the Debian X
Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the
XF86Config-4 manual page.
# (Type "man XF86Config-4" at the shell prompt.)
#
# This file is automatically updated on
xserver-xfree86 package upgrades *only*
# if it has not been modified since the last upgrade
of the xserver-xfree86
# package.
#
# If you have edited this file but would like it to be
automatically updated
# again, run the following commands as root:
#
# cp /etc/X11/XF86Config-4
/etc/X11/XF86Config-4.custom
# md5sum /etc/X11/XF86Config-4
>/var/lib/xfree86/XF86Config-4.md5sum
# dpkg-reconfigure xserver-xfree86

Section "Files"
FontPath "unix/:7100" # local font server
# if the local font server has problems, we can fall
back on these
FontPath "/usr/lib/X11/fonts/misc"
FontPath "/usr/lib/X11/fonts/cyrillic"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/Type1"
FontPath "/usr/lib/X11/fonts/CID"
FontPath "/usr/lib/X11/fonts/Speedo"
FontPath "/usr/lib/X11/fonts/100dpi"
FontPath "/usr/lib/X11/fonts/75dpi"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "keyboard"
Option "CoreKeyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "vga"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28-50
VertRefresh 43-75
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
 
Old 02-03-2008, 07:52 AM   #2
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,823

Rep: Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727Reputation: 727
Moved: This thread is more suitable in Linux-embedded and has been moved accordingly to help your thread/question get the exposure it deserves.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
electrotehcnics arm dev board + linux mrmz Linux - Hardware 3 03-19-2007 12:26 PM
ARM a8 architecture corbis_demon Programming 0 10-16-2005 07:31 AM
Which Distro is best for Internet Control of ARM board Squiggz Debian 0 09-08-2005 07:02 PM
USB mouse not working on the ARM board. manjunathk Linux - Hardware 1 07-12-2005 05:06 PM
How can i build ppp in a arm board which has uclinux os keer Linux - Networking 0 10-22-2003 08:35 PM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration