LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 06-23-2010, 01:49 PM   #1
lnevin
LQ Newbie
 
Registered: Jun 2010
Location: Boston area
Posts: 1

Rep: Reputation: 0
in u-boot, after using setenv serverip, then save, dhcp does not see new serverip


dhcp is unable to resolve:
in U-boot> dhcp
Retry count exceeded; starting again
BOOTP broadcast 1
DHCP client bound to address 172.23.16.143
TFTP from server 10.20.4.10; our IP address is 172.23.16.143; sending through gateway 172.23.16.1
Filename 'pxelinux.0'.
Load address: 0x400000
Loading: T T T T T T T T T T
I have used: setenv serverip <ip> then saveenv, printenv confirms it is set, but yet the server ip listed above persists.

I tried using setenv to put them on the same subnet, again, the change doesn't persist when I run dhcp.

I have 2 network setups with this board, they both fail in the same way. (Putty is used in both cases)
Here are the network setups in both cases:
1. The board's ethernet cable is hooked to the same router that my windows desktop is connected to. ( I would like the board to be able to grab flash images from a linux box- or a flash card)

2. The board's ethernet cable is directly connected to a linux box

---
I can't see where it is gettting the serverip or the IP address. I haven't set it and haven't yet found where it is being set. I have grep -r all over, no where do I see the serverip it is picking up.

Suggestions?

It is probably obvious that I am new to embedded linux.
 
  


Reply

Tags
dhcp, save, setenv, uboot


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SetEnv TZ Issues tuftystick Linux - Newbie 1 05-16-2009 04:55 AM
setenv not working??? birjodh Linux - Newbie 12 06-07-2007 01:51 AM
setenv command? BlueSpirit Slackware 6 08-13-2006 06:17 PM
Setenv IBP Linux - Software 3 12-20-2002 10:05 AM
setenv ???? toxic53 Linux - Networking 1 09-26-2001 12:30 PM


All times are GMT -5. The time now is 04:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration