LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices



Reply
 
Search this Thread
Old 06-09-2010, 12:53 AM   #1
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Rep: Reputation: 15
How to stop screen going blank in debian OS


Dear All,

how to use setterm command in debian I mean in /etc/xx files
 
Old 06-09-2010, 04:56 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Hi,

You can create a script in /etc/init.d to run setterm, e.g.:
Code:
#!/bin/sh
/usr/bin/setterm -blank 0
make it executable and run
Code:
update-rc.d scriptname defaults
so it updates the necessary symlinks in the various runlevels

Regards
 
Old 06-09-2010, 06:08 AM   #3
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
does not work

Quote:
Originally Posted by bathory View Post
Hi,

You can create a script in /etc/init.d to run setterm, e.g.:
Code:
#!/bin/sh
/usr/bin/setterm -blank 0
make it executable and run
Code:
update-rc.d scriptname defaults
so it updates the necessary symlinks in the various runlevels

Regards
thank you very much.


I have done as you mentioned

the step I followed is as follows

ot@ts7000:init.d# vi ww1
#!/bin/sh
/usr/bin/setterm -blank 0
root@ts7000:init.d# chmod 777 ww1
root@ts7000:init.d# ./ww1
oot@ts7000:init.d# update-rc.d ww1 defaults
Adding system startup for /etc/init.d/ww1 ...
/etc/rc0.d/K20ww1 -> ../init.d/ww1
/etc/rc1.d/K20ww1 -> ../init.d/ww1
/etc/rc6.d/K20ww1 -> ../init.d/ww1
/etc/rc2.d/S20ww1 -> ../init.d/ww1
/etc/rc3.d/S20ww1 -> ../init.d/ww1
/etc/rc4.d/S20ww1 -> ../init.d/ww1
/etc/rc5.d/S20ww1 -> ../init.d/ww1
root@ts7000:init.d# reboot




same after 10 minutes screen gone blank...
could you please suggest any wrong thing I did???


thanks once again for you kind reply
 
Old 06-09-2010, 06:43 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Hi,

It looks like you have to add some more setterm options
Code:
/usr/bin/setterm -blank 0 -powersave off -powerdown 0
 
Old 06-11-2010, 02:36 AM   #5
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
setterm -cursor off

Quote:
Originally Posted by bathory View Post
Hi,

It looks like you have to add some more setterm options
Code:
/usr/bin/setterm -blank 0 -powersave off -powerdown 0
Thanks for your suggestion still the same problem
I have even added

seterm -cursor off also to make cursor blinking off but after doing this also cursor is blinking....

please suggest any other method...
 
Old 06-11-2010, 03:00 AM   #6
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by lalithasankh View Post
Thanks for your suggestion still the same problem
I have even added

seterm -cursor off also to make cursor blinking off but after doing this also cursor is blinking....

please suggest any other method...
hey I always get following error

cannot (un)set powersave mode for
/usr/bin/setterm -blank 0 -powersave off -powerdown 0

please guide me how to resolve this issue
 
Old 06-11-2010, 03:29 AM   #7
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Are you running the command from an xterm? It is supposed to be run from CLI.
If you want to do the same for X you should use xset
 
Old 06-11-2010, 04:52 AM   #8
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bathory View Post
Are you running the command from an xterm? It is supposed to be run from CLI.
If you want to do the same for X you should use xset
I am using VI editor,I realyl don't know working with xterm
 
Old 06-11-2010, 05:04 AM   #9
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
xterm is a X-windows terminal. What I mean is that if you're trying to run the setterm command from a terminal inside X, it's not going to work.
It is supposed to work when you boot into runlevel 3 and not runlevel 5 (that is X-windows)
 
Old 06-11-2010, 05:35 AM   #10
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bathory View Post
xterm is a X-windows terminal. What I mean is that if you're trying to run the setterm command from a terminal inside X, it's not going to work.
It is supposed to work when you boot into runlevel 3 and not runlevel 5 (that is X-windows)
see actually working on TS7260 ARM-linux board. Once power is switched on I get login prompt on Hyper terminal(in windows xp Machine) and another on VGA Screen

now what even I have done on windows Hyperterminal(which is ttyAM0 of
TS7260 arm9 board)....

now tell me what is wrong that I am doing?????????????
 
Old 06-11-2010, 06:37 AM   #11
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
I don't think you're doing something wrong. I guess it's the customized debian you're running on this board.
You can leave the powersave option out the command and see if it works
Code:
/usr/bin/setterm -blank 0 -powerdown 0
 
Old 06-11-2010, 07:21 AM   #12
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bathory View Post
I don't think you're doing something wrong. I guess it's the customized debian you're running on this board.
You can leave the powersave option out the command and see if it works
Code:
/usr/bin/setterm -blank 0 -powerdown 0
thank you very much,

i went init 3 level
and executed the shell script and
updated rc.d as of ur 1st mail but for rebooting

I am saying to reboot and again getting same problem cursor in blink
and screen goes blank.
 
Old 06-11-2010, 08:12 AM   #13
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
If you're using console-tools, it's maybe worth trying to edit /etc/console-tools/config and use:
Quote:
BLANK_TIME=0
POWERDOWN_TIME=0
 
Old 06-11-2010, 08:54 AM   #14
lalithasankh
LQ Newbie
 
Registered: May 2010
Posts: 28

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bathory View Post
If you're using console-tools, it's maybe worth trying to edit /etc/console-tools/config and use:
sorry I am not able to find console-tools in /etc/ directory
 
Old 06-11-2010, 04:48 PM   #15
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Makes sense since you're using a customized debian.
The last thing I can think that it could work, is to use ansi escape codes to do the same as setterm:
Code:
echo -e '\033[9;0]\033[14;0]' > /dev/console
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blank Screen: Problem with ATI drivers with 9200 PRO and Debian Pelouse Linux - Hardware 6 02-11-2007 04:01 AM
Blank screen after 10-12 minutes on Debian kushalkoolwal Debian 1 02-02-2006 12:10 PM
SUSE 10 GNOME screen blank (MAKE IT STOP!!!) nstratton Suse/Novell 1 01-16-2006 02:46 PM
Blank screen when loading fglrx ATI drivers on Debian what_is_dot Linux - Software 10 11-10-2005 01:06 PM
How to stop screen from going blank jkraeger Linux - General 10 02-26-2003 11:36 PM


All times are GMT -5. The time now is 04:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration