LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices



Reply
 
Search this Thread
Old 11-10-2008, 05:16 AM   #1
subhashini.s
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Rep: Reputation: 0
Help me, Ethernet does not work in Linux


Hi everybody,

My board has
CPU: MPC8360E
Boot code version: u-boot-1.3.2
linux kernel version: linux-2.6.22(with updated patches).

My problem is:

In kernel, I am able to ping only my board, but when i try to ping a host system in LAN,it fails!

EXPLANATION:
Using bootm cmd,I loaded
kernel image: uImage,
ramdisk image:rootfs.ext2.gz.uboot taken from MPC8360E_PB_K26_20071012-LTIB.iso
and fdtfile.

From this, I concluded network card is ok.After bootm cmd,I got the console for Kernel.

Next I doubted Ethernet card, to confirm I executed the below commands and confirmed Ethernet card is working fine.

######################################################################
~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:9F:00:23:23
inet addr:192.168.0.254 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Base address:0x3200

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

~ # ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
NETDEV WATCHDOG: eth0: transmit timed out
UCC3 Fast registers:<6>Base address: 0xe100e200<6>
--- followed by more register dumps..after this it hangs--
#######################################################################

- But Network configuration is Ok.
- And Network card is OK.( eth0: Micrel KSZ8041TL PHY ).

But really, phy can't connect to outside network. I am able to ping to my board ip address, but when i try to ping a host in LAN fails!

What could be the problem here? Am I missing some configuration?

Last edited by subhashini.s; 11-11-2008 at 03:45 AM. Reason: I had made the query still clearer
 
Old 11-10-2008, 08:09 AM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
There's too much information here, but some things are missing.

First, what kind of internet connection do you have?--ie DSL, Cable modem, etc.?
Do you have a router?
Static IP or DHCP?

If eth0 shows in ifconfig, and "ifconfig up" works, then the driver for the card is OK.

You don't mention setting the IP address or using DHCP. If you have DHCP, you have to issue dhcpcd or dhclient to connect.

Have you tried setting things up with the GUI tools in your distro?
 
Old 11-10-2008, 09:39 AM   #3
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,095
Blog Entries: 2

Rep: Reputation: 111Reputation: 111
Do you have a default route? Without it you won't be able to see beyond your local ip block.
 
Old 11-11-2008, 03:24 AM   #4
subhashini.s
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Yeah, default route is set. Still i am not able to ping other than my system.
 
Old 11-11-2008, 03:26 AM   #5
subhashini.s
LQ Newbie
 
Registered: Nov 2008
Posts: 7

Original Poster
Rep: Reputation: 0
There is no DHCP to set ip address, it is static.
 
Old 11-11-2008, 08:04 AM   #6
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Quote:
Originally Posted by subhashini.s View Post
There is no DHCP to set ip address, it is static.
I asked you several questions---we can't help you if you don't provide complete information.
 
Old 11-14-2008, 10:29 PM   #7
twwwater
Member
 
Registered: Nov 2008
Posts: 113
Blog Entries: 1

Rep: Reputation: 15
waaaaaaa......
thank you all here,for that I met the same problem with subhashini.s
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tripped over ethernet cord, ethernet doesn't work anymore 1veedo Linux - General 2 10-21-2007 12:02 AM
ethernet doesnt work although linux recognises it wahming Linux - Newbie 6 02-09-2007 11:43 PM
Cannot get my Ethernet Port to Work With Linux saturninus Linux - Newbie 10 09-25-2004 06:51 PM
Help! troyble getting Ethernet card to work on Linux nwahster Linux - Laptop and Netbook 5 09-04-2003 11:44 PM
ethernet won't work busbarn Slackware 28 07-11-2002 11:17 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration