LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Embedded & Single-board computer (http://www.linuxquestions.org/questions/linux-embedded-and-single-board-computer-78/)
-   -   Compiling linux-2.6.26 for ln2440sbc (ARM9 core) (http://www.linuxquestions.org/questions/linux-embedded-and-single-board-computer-78/compiling-linux-2-6-26-for-ln2440sbc-arm9-core-670974/)

jituelect 09-19-2008 02:09 AM

Compiling linux-2.6.26 for ln2440sbc (ARM9 core)
 
hi,

I have a patch for linux-2.6.21 (http://free-opensource.qvantel.net
/mediawiki/upload/ln2440sbc-lp35/2.6.21/linux-2.6.21-ln2410sbc-
to-ln2440sbc.patch).

and also the same for linux-2.6.18.1(http://free-opensource.qvantel.net
/mediawiki/upload/ln2440sbc-lp35/2.6.18/fox-2.6.18.1-ln2440sbc-
0.7.patch).

Now I want to upgrade the linux-2.6.21 patch for linux-2.6.26 .
How to start upgrading patch for linux-2.6.26 ?

TIA
jituelect

Mara 09-28-2008 05:47 AM

First check if you can simply apply it. If yes, you just stop at this point (you may check, however, to see if the patch was included in the right places). If not, you need to find the fragment that doesn't apply then see what has changed in the kernel code between the versions and re-write the patch. Kernel changelog may be useful to see why the changes were made (it may be, for instance, that certain fragments of the patch are not longer needed).

jituelect 09-29-2008 10:46 PM

thanks
 
Thanks Mara for your suggestion


All times are GMT -5. The time now is 12:41 AM.