LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 06-17-2013, 07:30 PM   #1
Alexandrenagy
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Rep: Reputation: 0
Unhappy Booting Slackware Linux in a PC/104 Geode LX 500 Board without a plugged monitor.


Hello Everyone!

I am trying to boot the Slackware Llinux 13.37 in a PC/104 based on a Geode LX 500 processor.

The onboard computer is embedded on a air bearing table and uses a SSH comunication interface via Wifi.


Every time I am going to turn on the system, I need to plug in the monitor VGA 15-pin cable at the PC/104. If I do not do this procedure, the system does not boot. There is a moment during the booting process that the system get locked and does not go on.

For fixing the problem, I tried to set on boot options the following line:
vga=off

But it does not work. I also tried to use "video=off" but this property does not exist.

Is there a way to boot the Slackware Linux without the plugged monitor? What I am doing right now is waiting the system to complete the booting process and unplugg the cable. Then, I access the graphic mode through a notebook running X-Ming, a remote X server for Windows, via SSH (Putty).

Is there another kernel booting option that I may have tested?


I thank in advance for the help!

Best Regards,
Alexandre

Last edited by Alexandrenagy; 06-17-2013 at 07:31 PM.
 
Old 06-20-2013, 11:16 AM   #2
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
It may be that the X server is being launched, but that it is trying to query the monitor to find a suitable resolution or other parameters. If Slack uses the usual inittab configuration, try setting the runlevel to 3 to prevent startup of an X server.
--- rod.
 
Old 06-21-2013, 12:56 PM   #3
Alexandrenagy
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Original Poster
Rep: Reputation: 0
Thumbs up

Thank you for the answer!

Looking /etc/inittab, I found:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:


The runlevel is already configured as 3. The system starts in text-mode.

Looking again /var/log/dmesg, I found the line:

lxfb 0000:00:01.1: 121072 KB of video memory at 0xd0000000

When this kernel boot line is executed, the monitor blinks.
This is the exaclty momento that the system get locked if the VGA cable of the monitor is not attached.
If not attached, system get lock.
If attached, it continues the booting process.


I found this link after that:
https://www.kernel.org/doc/Documentation/fb/lxfb.txt

"This is a graphics framebuffer driver for AMD Geode LX based processors".
There is a command 'fbset' to configure the video resolution.

Well, I think I need to disable this video mode, but I still don't know how to do it.

Any guests?

Att
Alexandre.
 
Old 06-21-2013, 01:23 PM   #4
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
It appears that the driver is hanging the system during initialization. The driver can be either built into the kernel, or it can be a loadable module. If it is a loadable module, it should be simple enough to not load it; perhaps somewhere like modprobe.conf can be modified to remove it. If it is built in, then either it must be disabled, configured to behave better, or the kernel rebuilt to exclude it. The latter should always work, and would be my first approach. Otherwise, try to use the documented kernel arguments to make it play nice. Maybe simply specifying some resolution will cause it to not want to query the monitor (if that is indeed what's happening).
Do you want to always boot without a monitor?
--- rod.

Last edited by theNbomr; 06-21-2013 at 01:26 PM.
 
Old 06-21-2013, 07:31 PM   #5
Alexandrenagy
LQ Newbie
 
Registered: Jan 2011
Posts: 3

Original Poster
Rep: Reputation: 0
I will try to check if the module is built into kernel or loadable. I think it is built into.

I don't need the monitor INSIDE the satellite simulator (air bearing table).
I want to turn on the experiment and simply access it via SSH.
But, plugging the monitor every time and unplugging is a little boring.


I will test this and return new information on Monday. The system stays at the Laboratory, at work.

I really thank you for the tips.

Att.
Alexandre.
 
Old 06-22-2013, 12:30 PM   #6
theNbomr
LQ 5k Club
 
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,396
Blog Entries: 2

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Another thought that might work. If the monitor is being used as the console, you might be able to simply end-around that by specifying a serial port as the console (if there is a serial port, of course). The kernel arguments to do that are
Code:
console=ttyS0,115200
Of course, use the port designation appropriate to your system, and select a baud rate that you want, if you want to actually use the console. See the Linux Serial Console Howto for more details.

--- rod.

Last edited by theNbomr; 06-23-2013 at 12:51 AM.
 
Old 06-22-2013, 04:25 PM   #7
jefro
Guru
 
Registered: Mar 2008
Posts: 12,073

Rep: Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518Reputation: 1518
I agree that x or vga seems to be the issue.

"Q: Can I install using a console on a serial port?

Yes. Most of the bootdisks included with Slackware include support for putting the system console on a serial port. To do this, you need to use console=ttyS0 or console=ttyS1 (these examples would be for COM1: and COM2 as extra parameters on the bootdisk's boot prompt. "

Since it can be installed correctly without a monitor you may have to simply add it in later at boot time. I doubt you'd have to re-install it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to comunicate with PC/104 board using TS7260 in TS-Linux dmiralles2009 Linux - Newbie 0 07-05-2012 02:43 PM
Adding 3rd monitor / Slackware / Zotac - nvidia board linuxbird Linux - Hardware 3 02-19-2012 08:52 AM
Help needed in building a minimal linux for a PC-104 board rainbow82 Linux - Newbie 9 07-19-2011 05:10 PM
Geode chipset detects monitor wrong deadeyes Linux - Desktop 0 08-21-2008 04:43 AM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration