LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware > Linux - Embedded & Single-board computer
User Name
Password
Linux - Embedded & Single-board computer This forum is for the discussion of Linux on both embedded devices and single-board computers (such as the Raspberry Pi, BeagleBoard and PandaBoard). Discussions involving Arduino, plug computers and other micro-controller like devices are also welcome.

Notices

Reply
 
Search this Thread
Old 05-23-2013, 03:04 PM   #1
5883
Member
 
Registered: Aug 2004
Posts: 170

Rep: Reputation: 0
a strange issue that PHY cannot detects eth link up signal ?


Hi, we develop a board based on sam9m10g45ek evaluation board, the eth0 should be exactly the same as the eval board, uses macb.c as driver. Same phy chip. (In short, we cloned macb ethernet port HW & SW from Atmel)

Now once a while, we see eth0 link LED is off after rebooting the system.
1. From linux prompt, type “reboot”
2. Board reboots
3. If everything is ok, we should see green and amber LED for the ether port
4. Once a while, none LED is on from the above steps
5. We change the macb driver to be loadable module, when this happens, we rmmod, then insmod, won’t help.
“ip link” still says link DOWN.
6. Unplug and plug in the Ethernet cable solves the problem most of the time. But this cannot be a solution.

Have you seen this problem before ?

Any suggestion appreciated !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux redhat 5 does not detects my second eth card - eth1 ynatan Linux - Networking 1 08-22-2010 03:33 AM
How to reinstall a signal handler after exec ( Strange behaviour in signal handling ) lali.p Programming 0 09-20-2008 12:11 PM
Eth link comes up after reboot haydin Linux - Networking 1 09-14-2006 05:57 PM
strange eth problem with linux danda821 Linux - Networking 1 04-16-2006 04:53 PM
Eth link up/down indication prital Linux - Networking 2 11-30-2005 04:58 AM


All times are GMT -5. The time now is 05:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration