LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 12-13-2008, 12:39 AM   #1
Genji
LQ Newbie
 
Registered: Oct 2006
Distribution: Ubuntu and Gentoo (for now)
Posts: 3

Rep: Reputation: 0
Trying to run python-updater (need to unmask a package)


Ok, well first of all I was trying to set up gnome on my new gentoo install (this is the first time I've done this) and it was going fine, but halfway through emerge gnome it would stop with the error "no module named libxml2" After poking around I found out that to fix this I needed to update my python with python-updater. However when I try to do this it says

!!! All ebuilds that could satisfy "=sys-libs/cracklib-2.8.10" have been masked. etc

And so, after poking around more I found out that to unmask it I would have to either add "=sys-libs/cracklib-2.8.10" to /etc/portage/package.unmask or add "=sys-libs/cracklib-2.8.10 ~x86" to /etc/portage/package.keywords. I wasn't sure which, so I tried both and neither worked (my arch is x86 by the way.) So any ideas as to how I should unmask it now?

edit: fixed, turned out I didn't have 2.8.10, I had a later version, but python-updater was looking specifically for that version. After updating world, it conversely updated python, and then after that python-updater worked.

Last edited by Genji; 12-15-2008 at 05:49 PM.
 
Old 12-14-2008, 09:19 AM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
Try adding this to package.keywords:

sys-libs/cracklib ~x86

Also, check to see if the package has been "hard-masked" instead of just masked.
 
  


Reply

Tags
emerge, gentoo, gnome


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
software package updater in 12.1 ? james2b Slackware 9 11-12-2008 09:02 AM
I see this message when starting the Package Updater... What should I do? lawrence_lee_lee Ubuntu 4 12-21-2007 07:52 PM
FC6 Package Updater tommytomato Fedora 3 05-15-2007 06:03 AM
Hi Everyone! First Problem - Slow Package Updater Sharkskin Boy Linux - Newbie 4 03-24-2007 09:13 PM
Package updater hangs like it on dial up maprx Fedora 0 06-15-2006 05:05 AM


All times are GMT -5. The time now is 05:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration