LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 06-10-2002, 12:00 PM   #1
rivang
Member
 
Registered: May 2002
Location: Elkview, WV
Distribution: Slackware 10
Posts: 139

Rep: Reputation: 15
SuSE Session Type


On the SuSE login screen... what do you have to do to add additional session types?

The current session types listed are:

kde
windowmaker
fvwm2
gnome
mwm
twm
failsafe
I would like to give fluxbox a test and xfce.

Thanks...
 
Old 06-10-2002, 02:08 PM   #2
buzlink
LQ Newbie
 
Registered: May 2002
Location: Kansas City, KS (WY)
Distribution: SuSE 6.3, 8.0
Posts: 8

Rep: Reputation: 0
I think you just install the other window managers and they add them self to the list.

If I'm totally wrong you probably have to edit some config file.
I'm not sure, and good luck trying to get a response on here.
 
Old 06-10-2002, 02:49 PM   #3
rivang
Member
 
Registered: May 2002
Location: Elkview, WV
Distribution: Slackware 10
Posts: 139

Original Poster
Rep: Reputation: 15
With a little more digging... I found the xinitrc.config which is located in the /etc/skel/.xinitrc or $user/home/xinitrc.

Note the call to /usr/X11R6/bin/wmlist... wmlist looks like a routine that detects the windows managers that are installed.

So how could you add fluxbox to this? I have it installed but it wasn't detected as an available winman.

#!/bin/bash
#
# Sample .xinitrc for SuSE Linux
# This script is called from 'startx' when you start an X session
#

#
# In case everything goes wrong, we at least fall back to a plain xterm
#
failsafe="xterm -ls -T Failsave -geometry 80x24-0-0"
trap "exec $failsafe" EXIT SIGHUP SIGINT SIGPIPE SIGTERM SIGIO

#
# Some bash (1 and 2) settings to avoid trouble on a
# failed program call.
#
test -n "$BASH" && set +o posix
no_exit_on_failed_exec=1
type shopt > /dev/null 2>&1 && shopt -s execfail
set +e > /dev/null 2>&1

#
# This should be the default
#
export TERM=xterm

#
# choose a window manager
#
if test -n "$WINDOWMANAGER" ; then
WINDOWMANAGER=`type -p $WINDOWMANAGER`
fi
if test -z "$WINDOWMANAGER" ; then
if test -x /usr/X11R6/bin/kde ; then
WINDOWMANAGER=/usr/X11R6/bin/kde
elif test -x /usr/X11R6/bin/startkde ; then
WINDOWMANAGER=/usr/X11R6/bin/startkde
elif test -x /usr/X11R6/bin/fvwm2 ; then
WINDOWMANAGER=/usr/X11R6/bin/fvwm2
elif test -x /usr/X11R6/bin/wmlist ; then
for i in `/usr/X11R6/bin/wmlist` ; do
WINDOWMANAGER=`type -p $i`
test -n "$WINDOWMANAGER" && break
done
elif test -x /usr/X11R6/bin/twm ; then
WINDOWMANAGER=/usr/X11R6/bin/twm
fi
fi

if test -z "$WINDOWMANAGER" ; then
echo "Error: Unable to find a window manager. Please make sure you installed one!"
echo "Exiting..."
xmessage -timeout 10 -default okay -center -file - <<-EOF
Error: Unable to find a window manager. Please make sure you installed one!
Exiting...
EOF
exit 1
fi

#
# Load system and users resources if not already done
# (XSESSION_IS_UP set by xdm in $XLIBDIR/xdm/Xsession)
#
if test "$XSESSION_IS_UP" != "yes" ; then
XLIBDIR=/usr/X11R6/lib/X11
test -r $XLIBDIR/Xmodmap && xmodmap $XLIBDIR/Xmodmap
test -r $HOME/.Xmodmap && xmodmap $HOME/.Xmodmap
test -r $XLIBDIR/Xresources && xrdb -load -retain $XLIBDIR/Xresources
test -r $HOME/.Xdefaults && xrdb -I$HOME -merge $HOME/.Xdefaults
test -r $HOME/.Xresources && xrdb -I$HOME -merge $HOME/.Xresources
fi

# Start the XIM server
test -r $HOME/.xim && source $HOME/.xim

#
# Add your own lines here...
#


# day planer deamon
# pland &

#
# finally start the window manager
#
exec $WINDOWMANAGER

# call failsafe
exit 0


Here is the wmlist...

#!/bin/bash
# wmlist
# SuSE wmlist 2001, last updated Jul 18
#
# check for installed window managers
#

WMs="
kde
windowmaker
sawmill
enlightenment
blackbox
DyDe
9wm
afterstep
amiwm
bowman
cdesim
ctwm
dtwm
fvwm1
fvwm2
fvwm95
gnome
icewm
mlvwm
mwm
olvwm
olwm
piewm
qvwm
scwm
wm2
XFce
kde1
twm
xsplash
"

newWM=""
for wm in $WMs ; do
type -p $wm &> /dev/null && newWM="$newWM ${wm##*/}"
done

test -z "$newWM" && exit 1
echo $newWM
exit 0

Last edited by rivang; 06-10-2002 at 02:50 PM.
 
Old 06-10-2002, 05:24 PM   #4
manaskb
Member
 
Registered: Jan 2002
Location: India
Distribution: Suse , Mandrake
Posts: 121

Rep: Reputation: 15
I went through this whole excercise once when i tried to install flux box and start it using the kdm. I found a slightly easier way of doing this. I am using kdm and kde3.0.

1. Open kcontrol(Kde Control Center)->System->Login manager . Now open the tab for "Sessions" Here add a session "fluxbox".

2. This depends on where your installed the fluxbox. In my case I had it in /opt/fluxbox. So i created a link to fluxbox in my /usr/X11/bin.

X11/bin> pwd
/usr/X11R6/bin
X11/bin> ls -l fluxbox
lrwxrwxrwx 1 root root 24 May 30 15:51 fluxbox -> /opt/fluxbox/bin/fluxbox

When you try to login the next time , you should be able to see "fluxbox" in the kdm session options along with all other winmanagers.
Thanks,
Manas
 
Old 06-10-2002, 05:26 PM   #5
manaskb
Member
 
Registered: Jan 2002
Location: India
Distribution: Suse , Mandrake
Posts: 121

Rep: Reputation: 15
Quote:
Originally posted by manaskb

2. This depends on where your installed the fluxbox. In my case I had it in /opt/fluxbox. So i created a link to fluxbox in my /usr/X11/bin.
This should have been /usr/X11R6/bin.
 
Old 06-10-2002, 10:00 PM   #6
rivang
Member
 
Registered: May 2002
Location: Elkview, WV
Distribution: Slackware 10
Posts: 139

Original Poster
Rep: Reputation: 15
Thanks... that sounds like a better solution
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how do I type chinese in SUSE? anticuchos Suse/Novell 1 10-10-2005 04:03 AM
When I type "su" I can't type the pass (suse 9.1) MagiNegi Linux - Newbie 6 08-08-2004 03:59 PM
How to Add a Session Type to KDM? fcaraballo Slackware 3 04-19-2004 06:23 PM
howto remote session (kde, ...) on SuSE 9 fdurodie Linux - Newbie 2 04-11-2004 10:32 AM
How do I configure my standard Session-type erik_wout_ew2 Linux - Software 4 12-09-2003 11:02 AM


All times are GMT -5. The time now is 11:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration