LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on...

Notices

Reply
 
LinkBack Search this Thread
Old 07-28-2006, 01:23 AM   #1
gbratig
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Rep: Reputation: 0
Question Remove a ubuntu package in Debian Sarge


Hello, i have a problem. Recently i've installed a ubunto package in debian sarge, the libc6, the problem is that now i want to remove the libc6 from ubuntu, to install the libc6 from sarge, but when i do apt-get remove libc6 the following text is shown:

Reading Package Lists...
Building Dependency Tree...
The following packages will be REMOVED: aalib1 abiword-common abiword-gnome adduser akode alien amor amule-common analog apache2 apache2-common apache2-mpm-prefork apache2-utils apt apt-utils aptitude ark arts artsbuilder at atlantik atlantikdesigner autofs base-files base-passwd bash bc belocs-locales-bin bin86 bind9 bind9-host binutils bison bittornado bittorrent bluefish bsdmainutils bsdutils bug-buddy bzip2 capplets capplets-data cdrecord compiz console-common console-data console-tools coreutils cpio cpp cpp-3.3 cpp-3.4 cramfsprogs cron cupsys cupsys-bsd cupsys-client cupsys-driver-gimpprint cupsys-driver-gimpprint-data cvs dash dbus-1 dbus-glib-1 dc dcoprss debconf debconf-i18n debconf-utils debhelper debianutils defoma desktop-file-utils dhcp-client dia-common dia-gnome dia-libs dictionaries-common diff dirmngr discover1 dlint dnsutils docbook-dsssl docbook-xml docker dosfstools dpkg dpkg-dev dselect e2fslibs e2fsprogs ed eject enscript eog epiphany-browser esound evolution evolution-data-server exim4 exim4-base exim4-config exim4-daemon-light eyesapplet fam fdutils etc etc etc......

WARNING: The following essential packages will be removed
This should NOT be done unless you know exactly what you are doing!
apt libc6 (due to apt) libgcc1 (due to apt) libstdc++5 (due to apt)
base-files base-passwd (due to base-files) bash passwd (due to bash)
libncurses5 (due to bash) bsdutils coreutils libacl1 (due to coreutils)
debianutils diff dpkg dselect (due to dpkg) e2fsprogs e2fslibs (due to
e2fsprogs) libblkid1 (due to e2fsprogs) libcomerr2 (due to e2fsprogs) libss2
(due to e2fsprogs) libuuid1 (due to e2fsprogs) findutils grep gzip hostname
login libpam-modules (due to login) libpam0g (due to login) mount
ncurses-bin perl-base sed sysvinit initscripts (due to sysvinit) tar
util-linux slang1a-utf8 (due to util-linux) zlib1g (due to util-linux)
0 upgraded, 0 newly installed, 972 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 1755MB disk space will be freed.
You are about to do something potentially harmful
To continue type in the phrase 'Yes, do as I say!'
?]

If i say yes, my system will dont work any more (i think), what i must to do?, because if i say yes, apt and dpkg will remove, so how i install the new libc6?

Im in a big trouble.

Excuse me poor english.

See ya
Gabriel
 
Old 07-28-2006, 06:23 PM   #2
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
You could try apt-get dist-upgrade to see if the package will be replaced.........or.......dpkg -r libc6 to remove
 
Old 07-28-2006, 06:44 PM   #3
cougyr
Member
 
Registered: Nov 2003
Posts: 98

Rep: Reputation: 15
Is the libc6 from ubuntu causing any problems? Actually, is there a difference? Why not just leave it alone? Ubuntu is often just Testing. If there is a big issue, you could point your sources to Testing and do a dist-upgrade. Personally, I'd be tempted to simply leave well enough alone.
 
Old 07-29-2006, 08:04 AM   #4
gbratig
LQ Newbie
 
Registered: Jun 2006
Posts: 14

Original Poster
Rep: Reputation: 0
i solved the fu... problem!!, but i did with synaptic, i dont like that way, because im learning, but well, i was dessesperated and i wanted to solved now. Thanks for replys.


ErrorBound: i try, but nothing
cougyr: when i wanted to install nvidia drivers, say that the libc developement packaget is not installed, so i did apt-get install libc6-dev, but how i installed the ubuntu libc6, the libc6-dev from apt get, failes, so i try download libc6-dev from ubuntu packages, but nothing, when i did dpkg -i libc6-dev..... display an error of libc6 was not configure (previously apt-get install -f( but nothing. Thats the reason.

Thanks x your help.

Again, sorry me english.

See ya
Gabriel
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Remove all configuration files of a Package -- Ubuntu Drapper Drake Dimitriy Linux - Software 1 06-10-2006 01:58 AM
Downloading All Debian Sarge Package Files BillyGalbreath Debian 4 11-26-2005 11:00 PM
Mixing Ubuntu repositories with Debian 3.1 Sarge Rutnut Debian 8 07-01-2005 09:10 AM
remove Bind from Debian Sarge cccc Debian 2 06-08-2005 08:08 PM
How to remove software at Debian sarge? Mathsniper Linux - Newbie 6 02-16-2005 08:51 AM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration