LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 08-19-2003, 07:40 PM   #1
tekquest
LQ Newbie
 
Registered: Apr 2003
Posts: 13

Rep: Reputation: 0
Redhat Linux 7.2 > INIT: Id "X" respawning too fast


All,

I recently installed RH7.2 onto a Pentium 230 mmx, 64mb ram, 10gb hdd and when I rebooted for the first time, I get the error message:

INIT: Id "X" respawning too fast: disabled for 5 minutes and it continues to do this without fail.

I am new to Red hat and linux in general, I would appreciate any comments you might have, have I possibly installed it incorrectly?

I told the RH 7.2 installer to auto create my partitions and it happily did so, resolution for the "X" windows is 800 x 600

thanks all, appreciate your time,

Luke
 
Old 08-20-2003, 09:04 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,554

Rep: Reputation: 182Reputation: 182
"INIT: Id "X" respawning too fast: disabled for 5 minutes and it continues to do this without fail."

Startx hits some sort of error and fails. It then tries again (respawns) and hits the same error again. The error that is causing startx to fail could be anything.

To get control of the situation when it starts looping hit <Ctrl><Alt><F3> which will switch you to alternate console 3. Then login as root and start debugging the situation from the command line.

Look in /home/user/.xsession-errors for error messages. You also should use the X configurator program to check out how you have configured your X Window hardware. I don't use Red Hat but my guess as to the name of the Red Hat X configuration program is XF86config. Somebody please jump in here and spell it right.
 
Old 08-28-2003, 07:14 PM   #3
tekquest
LQ Newbie
 
Registered: Apr 2003
Posts: 13

Original Poster
Rep: Reputation: 0
i had a go at using the ctrl+alt keys, but nothing seems to stop it!!!

how about a fresh approach for my intranet machine, what linux dist would you recommend?

thanks for replying! :-D
 
Old 08-29-2003, 03:10 PM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,554

Rep: Reputation: 182Reputation: 182
" what linux dist would you recommend?"

One possible source of your problem is that you may be using a video card that is not supported by Red Hat 7.2, or perhaps USB devices. I recommend that you get the latest release of Mandrake, Red Hat, or SuSE.

Last edited by jailbait; 08-29-2003 at 03:12 PM.
 
Old 09-01-2003, 07:27 PM   #5
tekquest
LQ Newbie
 
Registered: Apr 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Its an S3 Trio 3D, 4mb card, i went through the setup, then x window system and it still appears to have difficulty recognising the video card..

tried to swap it over, but same stuff.. there is no way to use a "generic" card is there?

probably a good idea to go and buy the latest redhat, considering the time being spent messing around!!

thanks :-D
 
Old 09-01-2003, 08:02 PM   #6
tekquest
LQ Newbie
 
Registered: Apr 2003
Posts: 13

Original Poster
Rep: Reputation: 0
One more question, can I disable the X-windows system and use the Redhat linux 7.2 version remotely? e.g. as an intranet pc?

how would I go about accessing this system from lets say, a windows system?

thanks :-D
 
Old 09-02-2003, 02:14 PM   #7
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,554

Rep: Reputation: 182Reputation: 182
"can I disable the X-windows system "

Yes. You can simply run in command line mode. You would have to disable X Window during the install. I am not sure how to do that with Red Hat 7.2 but you want to tell the install to boot up to a command line instead of X Window.

If you did not have the startx problem you could change to a command line by changing the default run level.

Somebody else will have to answer your questions about a Linux/Windows interface because I know next to nothing about Windows. I suggest that you start a new thread in the Networking forum. Somebody there can answer your interface questions.

Last edited by jailbait; 09-02-2003 at 02:16 PM.
 
Old 09-02-2003, 07:43 PM   #8
tekquest
LQ Newbie
 
Registered: Apr 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks Steve, appreciate your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 07:18 PM
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 04:53 AM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 06:03 AM
INIT: Id "x" respawning too fast: disabled for 5 minutes" Lego3 Linux - Software 0 06-16-2004 08:01 AM
INIT: Id "x" respawning too fast: disabled 5 minutes maddskillz Mandriva 1 10-10-2003 10:06 PM


All times are GMT -5. The time now is 05:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration