LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 06-19-2003, 11:05 AM   #1
jsf03723
LQ Newbie
 
Registered: Jun 2003
Location: San Diego, CA, USA
Distribution: redhat 7/8/9, mandrake, smoothwall corporate 3.0
Posts: 20

Rep: Reputation: 0
Redhat 9: restricting reboot/shutdown from login screen


Redhat 9 is installed on a machine that I want to restrict reboot/shutdown access to.

With Redhat 9, I am presented with a GUI log in screen. At the bottom of that screen there are options for Preferences, Reboot, Shutdown, etc. If someone walks up to the console, they can choose to reboot or shutdown the system without being prompted for a password.

Ok, we can restrict access to /sbin/shutdown, /sbin/reboot, etc, so that only root can execute the reboot or shutdown from a command prompt, but I want to restrict it from the console.

How can I restrict these options from the GUI log in screen?

Thanks for your help,
Jim
 
Old 06-19-2003, 12:02 PM   #2
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
Did you try to chmod 700 /sbin/shutdown and chmod 700 /sbin/reboot.
 
Old 06-19-2003, 03:56 PM   #3
jsf03723
LQ Newbie
 
Registered: Jun 2003
Location: San Diego, CA, USA
Distribution: redhat 7/8/9, mandrake, smoothwall corporate 3.0
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, tried that, neither helped. There is a confirmation dialog box after selecting "Shutdown" or "Reboot" but there is no means of authenticating that the user should actually be doing that.

Other thoughts?
 
Old 06-19-2003, 07:39 PM   #4
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
Go to your K on the task bar, then preferences, then system and then login manager. In the sessions tab there is a commands section where the path is set for halt and reboot. you could just clear the paths. I do not boot to a gui so I have not tried it. It is a little half _ss fix but should work.
 
Old 06-19-2003, 07:39 PM   #5
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
Go to your K on the task bar, then preferences, then system and then login manager. In the sessions tab there is a commands section where the path is set for halt and reboot. you could just clear the paths. I do not boot to a gui so I have not tried it. It is a little half _ss fix but should work.
 
Old 06-19-2003, 07:55 PM   #6
jsf03723
LQ Newbie
 
Registered: Jun 2003
Location: San Diego, CA, USA
Distribution: redhat 7/8/9, mandrake, smoothwall corporate 3.0
Posts: 20

Original Poster
Rep: Reputation: 0
That sounds like a reasonable way to do it, alas, I do not have a Preferences->System option. Nothing between Sound and Themes, as either a user or root.

There must be a text file that it saves its definitions to, any idea on where that might be?

Thanks for the ideas,
Jim
 
Old 06-19-2003, 08:15 PM   #7
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
I think to get them you need the kdeadmin or kdeutils to do that. They should be on you cd. They should allow you to do it.

Also you might want to checkout /opt/kde/share/config/kdm/kdmrc file. About the third of the way down there is a rebootcmd= and a haltcmd= . This is what I think you are looking for.
 
Old 06-20-2003, 10:33 AM   #8
jsf03723
LQ Newbie
 
Registered: Jun 2003
Location: San Diego, CA, USA
Distribution: redhat 7/8/9, mandrake, smoothwall corporate 3.0
Posts: 20

Original Poster
Rep: Reputation: 0
I will have to investigate those packages. I do not have them installed. The resource file you identify is not present at that location, nor could I find it on the system.

Thanks for the pointers to date,
Jim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable remote login shutdown/reboot student04 Linux - Security 1 03-06-2005 08:29 PM
No "system" button on login screen so as to shutdown farpoint Debian 2 11-26-2004 06:36 PM
Newbie: how to turn off the computer, reboot, how to find the login screen, and vt's jimothy05 Slackware 13 09-29-2004 05:48 PM
shutdown fron GUI login screen ? alloydog Slackware 12 06-05-2003 11:33 AM
RedHat login screen. Citizen Bleys Linux - General 1 08-14-2001 05:04 AM


All times are GMT -5. The time now is 03:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration