LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 04-26-2003, 07:36 AM   #1
michel v
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Rep: Reputation: 0
Redhat 9 install/upgrade problem: XFree gives a black screen


hi,

I tried to do a clean install of RH9 this morning. When letting it start in graphical mode, I get a black screen. When letting it proceed in text mode, I can install everything just fine but I get a black screen when XFree 4.3 is supposed to start.
Then I tried an upgrade from RH8 (which works just fine), and encountered the same problem.

My video card is a Riva TNT2 with 64MB memory (it usually gets recognised as 32MB by all hardware probes, though it really has 64MB).

Anyone had the same problem? How did you fix it?

Last edited by michel v; 04-26-2003 at 07:39 AM.
 
Old 04-26-2003, 09:02 AM   #2
jt1020
Member
 
Registered: Apr 2003
Location: root@localhost
Distribution: Fedora Core 5, Ubuntu, Debian
Posts: 537

Rep: Reputation: 30
maybe because your video card is not supported by linux or you must download drivers so that linux can use your video card.
 
Old 04-26-2003, 09:39 AM   #3
michel v
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Original Poster
Rep: Reputation: 0
RH 8 works just fine with that video card, thanks.
I guess I should try installing RedHat 8, then the nVidia drivers, then upgrade to RH 9...
 
Old 04-26-2003, 12:58 PM   #4
michel v
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Follow-up: I just tried to install Mandrake 9.1, and I got the same problem: XFree86 starts, but with a black screen and there's nothing I can do then.
So it's likely an issue with XFree86 4.3...
 
Old 04-26-2003, 08:53 PM   #5
michel v
LQ Newbie
 
Registered: Apr 2003
Posts: 7

Original Poster
Rep: Reputation: 0
OK, I dealt with the problem.

Here's the problem: XFree 4.3's driver 'nv' has issues with Riva TNT2 cards (at least those).
Solution: get into command line and install nVidia's latest driver, then edit the XF86Config files as explained in the nVidia install process.
Second problem: Redhat doesn't give you the choice to boot into command line.
Solution: I ended up installing Mandrake 9.1. :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 12:52 PM
XFree-4.3.0 black screen killdos *BSD 4 10-11-2004 12:05 AM
Black screen of death after trying to upgrade BajaNick Linux - General 2 04-04-2004 04:44 AM
black screen on install? (hardware problem?) Matt_UK Linux - Newbie 4 12-28-2003 06:23 AM
black screen on RedHat 9.0 VirtualJam Linux - General 2 08-22-2003 02:51 PM


All times are GMT -5. The time now is 01:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration