LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices



Reply
 
Search this Thread
Old 03-13-2003, 07:57 PM   #1
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Rep: Reputation: 0
Question Red hat 8.0 Install - Video driver not recognised Intel 82845G


Hi,

I have just installed Red Hat 8.0 on my IBM Netvista 8309-51A dual booting with Windows XP Home

The graphical install failed with the message "could not open monitor"

i used "linux text" to install in text mode. xcustomisation failed for the same reason as th graphical install

I now have graphical desktop that is of a low resolution, the game tuxracer is extremely slow & erratic and when applications are run (say vi editor) a set of repeating lines appears ~2/3 the way down the screen . when the application is shut down the word Trash under the trash an is repeated dowwn the screen

I suspect that my problem is with my video driver. I have an Intel 82845G/GL video card according to my Windows environment

I have searched Intel site for a video driver for Linux and have found the following gz file i830-20030120-i386-linux.tar.gz and downloaded it to a floppy formatted with the FAT file system and also a document explaining how to install

the document raises things of which i am not terribly sure at this time being new to the linux environment and so am asking for some assistance which might require several posts as i come across each problem.

I guess the first one is :

can i read this archive file from the floppy disk onto my linux file system?. the file is
i830-20030120-i386-linux.tar.gz

this seems to a compressed file (i830-20030120-i386-linux.tar) within a compressed file. I am able to see the contents within Winzip under Windows...which one do i need .gz or .tar...presumably i will need to use the command tar to copy to linux

looking forward to any assistance anybody can give me
 
Old 03-13-2003, 08:11 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Gidday mate :)

can you do
Code:
lspci | grep -i vga
as root on your box and tell us the output?


From my understanding the i845 should be
compatible with i810 and i830 graphics chips.

Instead of Xconfigure (or what the RedHat tool
is called :}) try a Xfree86 -configure and follow
the steps it tells you.

You might want to try to use xf86cfg (comes
with XFree, graphical) or xf86config (comes
with XFree, text-based) if you know your
machines and monitors spec's.

Cheers,
Tink
 
Old 03-14-2003, 03:58 PM   #3
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Original Poster
Rep: Reputation: 0
Hi Tink,

the lspci | grep -i vga

gave me

00:02.0 VGA compatible Controller : INTEL CORP 82845G/GL [BROOKDALE -G] Chipset Intregrated Graphics Device (rev 01)

mmm.... this looks like it has picked it up ok doesnt it?

where do i go from here?...
 
Old 03-16-2003, 03:11 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Gidday Dave,

and it seems to be known to the kernel...

If the RH Tool doesn't pick it up correctly
use the tools (methods) supplied by XFree
as I suggested earlier...

Quote:
Instead of Xconfigure (or what the RedHat tool
is called :}) try a Xfree86 -configure and follow
the steps it tells you.

You might want to try to use xf86cfg (comes
with XFree, graphical) or xf86config (comes
with XFree, text-based) if you know your
machines and monitors spec's.
Cheers, and best regards from windy Wellington,
Tink
 
Old 03-16-2003, 06:43 PM   #5
UnTamed
Member
 
Registered: Dec 2002
Location: Qc, Canada
Distribution: CRUX
Posts: 317

Rep: Reputation: 30
If you want something other than vesa, you'll require XFree-4.3.0 and possibly a new drm kernel module ...IIANM.
 
Old 03-16-2003, 08:21 PM   #6
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Original Poster
Rep: Reputation: 0
hi tinkster,

is xfree86 available within red hat 8.0 as a command or is it something i have to download...i am not at my machine at the moment

also whilst i am havng trouble with my graphical environment is there an easy to terminate the x server & return to a shell prompt as all i use is the terminal to get a shell for compiling anyway at the moment. i have read that if i click on the desktop under some implimentations i should get options to shut down x but this does not work under gnome (i tried left, right,both mouse buttons)..also if i hit ctrl-alt-backspace..this shuts down everything ok but it puts me back to the graphical signon..also i cannot see any menu options anywhere under the red-hat icon on the task bar to shut down x

i have searched this site also for how to do this with no success

i have also read that if i shut down the window manager process this will also shut down x but this seems very inelegeant

is there a stopx as opposed to a startx that you can execute from the terminal?

Last edited by davmer; 03-16-2003 at 08:25 PM.
 
Old 03-16-2003, 09:05 PM   #7
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
You will have to change this file

/etc/inittab

look for this line:

id:5:initdefault and chage it to id:3:initdefault

before making this change make a backup copy

cp /etc/inittab /etc/inittab-old

This will make it so you boot into console mode and then when you want to use X type startx, and if you can't logout of X you use the ctrl-backspace and it will drop to console mode.
 
Old 03-16-2003, 10:02 PM   #8
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Original Poster
Rep: Reputation: 0
thanks jaycnrs,

i will try your suggestions.....
 
Old 03-16-2003, 11:32 PM   #9
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Hi Dave!

Quote:
is xfree86 available within red hat 8.0 as a command or is it something i have to download...i am not at my machine at the moment
Sure is ... that's what you are using when you are
in any kind of GUI in Linux ;)

Quote:
shut down x
When you go to a terminal
(Ctrl-Alt-F1, ie) do a
ps -A | grep dm
if you see gdm or kdm, try a
kill -9 <PID>

No such thing as stopx...

As for the names of the tools :)
su -
and then try
xf86cfg
or
XFree86 -configure
or
xf86config

Note: Linux is CASE-SENSITIV ;)

Cheers,
Tink

Last edited by Tinkster; 09-08-2005 at 03:38 AM.
 
Old 03-17-2003, 12:18 AM   #10
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Original Poster
Rep: Reputation: 0
tinker...did you notice jaycnrs' response (post #7) above for getting into console mode (which i presume is what i understand as a shell) either from within x or starting there by default?
 
Old 03-17-2003, 03:08 AM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,005
Blog Entries: 11

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Sure did, why are you asking? :)
Did you set it up to boot console
by default?

However, Ctrl-Alt-Backspace won't
kill xdm, kdm or gdm, and you'll end-up
(as you apparently noticed) with a
graphical login-screen :}



Cheers,
Tink
 
Old 03-17-2003, 05:24 PM   #12
davmer
LQ Newbie
 
Registered: Mar 2003
Location: Tasmania, Australia..the best place in the world..clean air & clean water..purely subjective of course!!!
Distribution: Red Hat 8.0
Posts: 20

Original Poster
Rep: Reputation: 0
hi jaycnrs,

well...ctrl-backspace does not seem to return to the shell from gnome..any comment?

there were 2 processes with gdm...i took the one with highest PID and killed it (kill -9 <PID>) and straaaaange things started to happen on my screen..perhaps i should have killed the lower one...so generally i feel a bit uncomfortable about this method

since you pointed me in the direction of inittab, i went to my reference ("Running Linux" (O'Reilly)) and read up on inittab and now i have some understanding about how that works... as i was doing this late last night i did not get a chance to actually do it...i will change the initdefault line to 3 & see how i go from there

i do think it weird though that there is not a way that the GUI does not provide a method by means of its interface to unload itself so that you get back to the shell...although when you think about it but windows (sorry for mentioning this word) doesnt either for that matter

thanks to everybody for your continued comments & suggestions...you are a great help
 
Old 03-20-2003, 02:53 AM   #13
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Yes, once you have it set to id:3:initdefault using
ctrl-alt-backspacewill kill the window manager and drop you to console mode, however if it is set to id:5:initdefault it will just boot you back into gui.

Also as tinker said above using ctrl-alt-F2 will bring up a console but will not kill your gui.

You might also want to run redhat-config-xfree86 which is a graphical way of producing a XF86Config file or xf86config which is text based, and then try the VESA generic driver.

Once you have completed this test it out by using startx if it works your on your way.

As for what you downloaded you should be able to boot into linux and use mount /mnt/floppy if that doesn't work then type mount -t vfat /dev/fd0 /mnt/floppy and you should be able to read the disk contants by cd /mnt/floppy then using ls If you can read it then read the README file less README and then you can copy the file to your hd using the cp *.tar.gz /home/usernamewhich will put the tar file in your home directory then cd /home/username once in this directory use tar -zxvf i830-*.tar.gz this will extract your files to a directory in your home (probably file name without .tar.gz) just run ls and you should see a new directory cd into this and follow the instructions that came with your tar file usually a README.

Don't forget to umount /mnt/floppy and pop out your floppy

Once you have X running properly then you will be able to switch your /etc/inittab file back to id:5:initdefault if you prefer a graphical login.
 
Old 03-20-2003, 02:55 AM   #14
JayCnrs
Member
 
Registered: Mar 2003
Location: Winnipeg
Distribution: Suse 9.3 Pro
Posts: 404

Rep: Reputation: 30
Getting late forgot to mention to quit reading the README file just hit q
 
Old 03-20-2003, 06:33 AM   #15
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
G'day Dave, Tink...........
XFree86-4.3.0 has 845 improvements, but so does the kernel, the updates are already in 2.4.21-pre#, the problem is you have to build it yourself :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82845G video driver problems tdejong Linux - Hardware 16 01-29-2008 11:16 PM
Installing Intel 82845G Video Driver after 2.6.9 Kernel Upgrade audibel Debian 14 11-28-2004 01:21 AM
Video Driver Poblems with Red Hat 8.0 (trident video driver) AstroJim Linux - Newbie 1 05-20-2004 04:25 PM
Video overlay on Intel Corp. 82845G/GL? Muzzy Linux - General 1 04-21-2004 04:26 PM
intel 740 video card & Red Hat 9 GAZ082 Linux - Distributions 0 06-05-2003 01:21 PM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration