LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 12-28-2004, 07:17 PM   #1
tgo
Member
 
Registered: Dec 2004
Posts: 125

Rep: Reputation: 15
problem with unbuntu


i was trying to install firestarter firewall and it said that i need an xml parser so i googled the error message and did what it said which was sudo perl -MCPAN -e shell then install XML::Parser ... now when i did this the xml parser gave lots of errors and didnt install.

So i went to the site for the parser download the same version and replaced the one i have and still got the same problem .... So then i downloaded an older version but the system wouldnt read from it.

has anyone else had this problem? does anyone know how to fix it?
 
Old 12-28-2004, 07:25 PM   #2
speel
Member
 
Registered: Apr 2004
Location: queens , nyc
Distribution: Slackware , Ubuntu
Posts: 349

Rep: Reputation: 30
open up synaptic and click search and type xml parser or come on the ubuntu channel on irc.freenode.net
 
Old 12-28-2004, 07:46 PM   #3
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
well i looked in synaptic but couldnt find the file to run it ... i installed it earlier and had the same problem

and also what would that search do? because the firewall only checks that file for an xml parser i dont think it would let me use any other.
 
Old 12-28-2004, 07:56 PM   #4
speel
Member
 
Registered: Apr 2004
Location: queens , nyc
Distribution: Slackware , Ubuntu
Posts: 349

Rep: Reputation: 30
can you post the ./configure error here
 
Old 12-28-2004, 08:00 PM   #5
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
I did not config i was trying to install the xml parser so i could install my firewall (firestarter)

so i did:

sudo perl -MCPAN -e "install XML::Parser"

and got many many errors
from the file
 
Old 12-28-2004, 08:14 PM   #6
speel
Member
 
Registered: Apr 2004
Location: queens , nyc
Distribution: Slackware , Ubuntu
Posts: 349

Rep: Reputation: 30
do you have libxml-parser-perl installed?
 
Old 12-29-2004, 11:18 AM   #7
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
i installed that and everything is working thanks

but one more quesiton .. i went to run another app and it didnt do anything and looked through the properties and it said nothing was set to run apps with type of 'executable' i know what its saying but what should i set it run with.
 
Old 12-29-2004, 08:32 PM   #8
speel
Member
 
Registered: Apr 2004
Location: queens , nyc
Distribution: Slackware , Ubuntu
Posts: 349

Rep: Reputation: 30
ah sorry i never used firestarter
 
Old 12-29-2004, 09:34 PM   #9
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
ok i think this error is generic and not firestarter based ..

checking for libgnome-2.0 >= 2.0.0
libgnomeui-2.0 >= 2.0.0
gtk+-2.0 >= 2.4.0
gnome-vfs-2.0 >= 2.6.0
libglade-2.0 >= 2.3.6... Package libgnome-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnome-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnome-2.0' found

configure: error: Library requirements (libgnome-2.0 >= 2.0.0
libgnomeui-2.0 >= 2.0.0
gtk+-2.0 >= 2.4.0
gnome-vfs-2.0 >= 2.6.0
libglade-2.0 >= 2.3.6) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.




im pretty sure i need to update somethign but i have the laste pkconfig and i think i installed libgnome2.0-dev but im still getting these errors .. is there one package that updates all these things or are they indivual?
 
Old 12-30-2004, 03:12 AM   #10
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
sorry to ask , but why dont u install firestarter from synaptic or apt-get instead ??

http://ubuntuguide.org/index.html#firestarter

Last edited by heema; 12-30-2004 at 03:14 AM.
 
Old 12-30-2004, 12:20 PM   #11
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
i have tryed that before also and got this:

Reading Package Lists... Done
Building Dependency Tree... Done
firestarter is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 71 not upgraded.


im pretty sure my only problem is that i need the 'libgnome-2.0' package and i looked through the package manager of ubuntu and did not find it. I then googled and still nothing. Next i went into the ubuntu irc and was told to install libgnome-2.0 so i did and i still get the same error
 
Old 12-30-2004, 02:05 PM   #12
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
have u added the universe repository ??
 
Old 12-30-2004, 02:15 PM   #13
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
i believe i have .... if added 'universe' in the all places where you download from in the package manager

if this is wrong or if its easy to explain could you tell me the proper way to add the universe repository

EDIT:

lignome2-0 is added and libgnome2-dev is already installed ... is that all i need or is there some other file needed?

Last edited by tgo; 12-30-2004 at 02:20 PM.
 
Old 12-30-2004, 02:21 PM   #14
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 46
open synaptic then tools or options i cant remember
then repository

make sure that every repository is checked then reload
 
Old 12-30-2004, 02:37 PM   #15
tgo
Member
 
Registered: Dec 2004
Posts: 125

Original Poster
Rep: Reputation: 15
man thanks for all the help i finally got it with the help of someone in the irc channel plus the stuff you said
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
downloading with unbuntu cypress42 Linux - Newbie 4 11-14-2005 04:10 PM
AOL on UNBUNTU? ikagan Linux - Newbie 6 09-18-2005 08:20 AM
frustrated with unbuntu, want to try something new whorush Linux - Distributions 16 07-08-2005 12:50 AM
Unbuntu 5.04 Solved my Problems! Snipersnest Linux - Newbie 4 03-09-2005 09:39 PM
Unbuntu 4.10 webwolf70 Linux - Distributions 14 10-30-2004 08:35 PM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration