LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on...

Notices

Reply
 
Search this Thread
Old 08-31-2004, 08:15 AM   #1
slackware_03
LQ Newbie
 
Registered: Aug 2004
Location: Philippines
Distribution: slackware
Posts: 12

Rep: Reputation: 0
poor sound quality


i need help on getting audio. i already configured my soundcard, which is ac97, to it already works but what i hear from the speaker is awful. it worked just fine on redhat and windows. but on slackware, it was not the same. i set my volume high and get little sound and it's just bad. hope someone can help me out!!!

i'm in desperate need of help!!!
 
Old 08-31-2004, 08:54 AM   #2
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
slackware_03; umm! as u discribed worked ok on other distros but not on this 1, & sound via spkrs not good (maybe bad) well check inside case where connections to sound are & visually check if those cables are not touching anywhere they may ground . even if speakers are external those
cables inside case if grounded will cause poor/no sound.
 
Old 08-31-2004, 07:49 PM   #3
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Quote:
Originally posted by penguin4
slackware_03; umm! as u discribed worked ok on other distros but not on this 1, & sound via spkrs not good (maybe bad) well check inside case where connections to sound are & visually check if those cables are not touching anywhere they may ground . even if speakers are external those
cables inside case if grounded will cause poor/no sound.
penguin4 -- as slackware_03 described, the speakers and sound card do have acceptable performance under Windows as well as under Redhat, and it's only under Slack that the performance is poor. Thus, based on the problem description, it would be extremely unlikely that the reported problem is being caused by either the speakers suddenly going bad, or that the cables are at fault. If those conditions were true, then the sound quality would be negatively affected regardless of which OS was running.

slackware_03 - if you have to turn the speaker volume up in order to hear the sound, then it may be that your volume levels are set very low or are muted. Try running this and verify that you sound levels are turned up sufficiently
Code:
alsamixer
Good luck with it -- J.W.
 
Old 09-01-2004, 12:17 AM   #4
slackware_03
LQ Newbie
 
Registered: Aug 2004
Location: Philippines
Distribution: slackware
Posts: 12

Original Poster
Rep: Reputation: 0
J.W. - i already raise the volumes on alsamixer very high. and only setting the mixer's volume really high would give me little sound and it was kinda blurry and foggy. for short, it was bad. i was thinking of installing newer version of kernel hoping it might solve the problem.
 
Old 09-17-2004, 06:54 AM   #5
orgee
Member
 
Registered: Sep 2004
Distribution: slack-10 / kernel-2.6.81
Posts: 43

Rep: Reputation: 15
hey are you still getting poor quality on sound? i have this problem right now and im searching all over for a solution so im wondering if youve got it fixed.
 
Old 09-18-2004, 01:11 PM   #6
rip
Member
 
Registered: Apr 2003
Location: Ohio
Distribution: PCLinuxOS
Posts: 97

Rep: Reputation: 15
When I had a problem like this, I fixed it by running aumix and adjusting the levels.

Don't know if running alsamixer accomplishes the same thing. Wouldn't cost anything to try.
 
Old 09-20-2004, 01:29 AM   #7
walmartshopper
Member
 
Registered: Sep 2004
Distribution: Slackware64-current multilib
Posts: 32

Rep: Reputation: 16
I had a problem with my sound being distorted in kde and there are two ways i've found to fix it. The first is to use any one of the volume controllers such as kmix or alsamixer and turn the PCM down to around 50% (only the PCM slider seems to affect the distortion.) The second solution is to open artscontrol and turn down the master volume to around -6 dB. It seems that arts clips at its default volume (possibly because my audigy outputs a slightly boosted signal.) I use the PCM method, but there are downsides to both solutions. Some programs such as mplayer use the PCM for volume control, and it's easy to forget about that and end up with distortion again. Using artscontrol seems like a better solution because it allows you to freely adjust the PCM level with no distortion. The problem with this (at least in kde 3.2.1) is that when you restart arts it resets itself to the default volume. I haven't found a way to get around this yet. I know you can go into kcontrol and save the current volumes, but it doesn't save the arts master volume. My plan was to automatically run a dcop call when kde started that would change the arts master volume, but I couldn't find any that did the job.

Hopefully this fixes your sound problem or at least leads you in the right direction.

So does anybody know a way to save the arts master volume? Or could someboy with kde 3.3 test it out and see if it saves the master volume? Any ideas would be appreciated. Thanks.
 
Old 09-20-2004, 08:29 AM   #8
slackware_03
LQ Newbie
 
Registered: Aug 2004
Location: Philippines
Distribution: slackware
Posts: 12

Original Poster
Rep: Reputation: 0
as for me, i never really solved this problem. but i have read that alsa in slack 10 is based on kernel 2.6. just maybe it might solved this problem though i never really tried it. also if you have a new motherboard, try checking the driver.

i found a linux driver on my cd but it was based on kernel 2.2 so i wasn't able to install it either.
 
Old 09-21-2004, 11:20 PM   #9
JrLz
Member
 
Registered: Mar 2004
Location: Jakarta
Posts: 164

Rep: Reputation: 30
yup, I've had that problem in slack 9.1 (problem in kde)and it's ok in slack 10
 
Old 09-23-2004, 01:09 PM   #10
jelmerderonde
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
I think I found a solution to the problem:
In kmix switch to advanced mode, and then activate IEC958 In Monitor.
If this doesn't work, try some other advanced options in kmix.

--Jelmer
 
Old 09-23-2004, 04:17 PM   #11
Junior41180
Member
 
Registered: Dec 2003
Location: Florida
Posts: 157

Rep: Reputation: 30
Quote:
Originally posted by walmartshopper
I had a problem with my sound being distorted in kde and there are two ways i've found to fix it. The first is to use any one of the volume controllers such as kmix or alsamixer and turn the PCM down to around 50% (only the PCM slider seems to affect the distortion.) The second solution is to open artscontrol and turn down the master volume to around -6 dB. It seems that arts clips at its default volume (possibly because my audigy outputs a slightly boosted signal.) I use the PCM method, but there are downsides to both solutions. Some programs such as mplayer use the PCM for volume control, and it's easy to forget about that and end up with distortion again. Using artscontrol seems like a better solution because it allows you to freely adjust the PCM level with no distortion. The problem with this (at least in kde 3.2.1) is that when you restart arts it resets itself to the default volume. I haven't found a way to get around this yet. I know you can go into kcontrol and save the current volumes, but it doesn't save the arts master volume. My plan was to automatically run a dcop call when kde started that would change the arts master volume, but I couldn't find any that did the job.

Hopefully this fixes your sound problem or at least leads you in the right direction.

So does anybody know a way to save the arts master volume? Or could someboy with kde 3.3 test it out and see if it saves the master volume? Any ideas would be appreciated. Thanks.
Not in linux right now, so I can't check ATM, but I know there is a way.

this solution is how I fix my problems, seems ALSA doesn't like my Bass, it sounds real bad, so I drop that lower than 50% and all is good
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poor sound quality on ALC850 onboard sound (FC3) c_ryan Linux - Hardware 3 05-20-2005 03:58 AM
Poor sound quality in linux? Jilted Linux - General 6 09-27-2004 06:59 AM
ALSA poor sound quality hamish Linux - Hardware 3 04-09-2004 05:00 AM
poor sound quality MDK 10 gurty Mandriva 2 03-24-2004 08:11 PM
two soundcards and poor sound quality joemamma Linux - Hardware 0 02-23-2003 11:00 PM


All times are GMT -5. The time now is 02:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration