LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on...

Notices

Reply
 
LinkBack Search this Thread
Old 05-09-2004, 01:34 PM   #1
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Rep: Reputation: 0
NVIDIA GeForce FX Go5200 & Suse 9.0, 3D graphics thing won't work!


Hello,

installed Suse 9.0 a month ago and still don't seem to have it working like is should!

Latest problem is the NVIDIA graphics card driver. Used YOU to download and install the driver like the NVIDIA website said but the 3D acceleration stuff is still disabled... There was some notes in the readme saying that some older Suse versions would have an error saying that 3D was disabled but that you should ignore it and it would work all the same.

Unfortunately it's not working, when I try and run the Armagetron game that comes with Suse, it says that there is no 3D card and then it crashes...

Can anyone help me?

Cheers.
 
Old 05-09-2004, 04:07 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Have you tried editing /etc/X11/XF86Config ? in the section "Module", uncoment the line
# Load "glx"
so it reads
Load "glx"
 
Old 05-09-2004, 06:15 PM   #3
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks for the suggestion, the NVIDIA site mentioned the XF86Config file as well but I checked it and the Load "glx" is there... but still not working...
 
Old 05-10-2004, 04:12 PM   #4
squid69
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Go to YOU,update driver only,go into terminal as root type "init 3"
when into this get into root mode and type "sax2 -m o=nvidia" 0 is number not letter
when you get into sax2,edit config, go to 3d thingy and enable 3d and save
It should load up with nvidia logo before desktop loads

hope all works sorry its pretty vague but its pretty self explanatry

Last edited by squid69; 05-10-2004 at 04:13 PM.
 
Old 05-11-2004, 06:35 PM   #5
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Excellent,

thanks squid69, I'll try that just as soon as I work out how to get my mouse working again! Like an idiot I re-configured my mouse to try and get the wheel to work and now can't use the mouse at all!...

you don't know how to configure the mouse from the failsafe mode do you?! It's a microsoft Wheel Mouse Optical USB and PS/2 Compatible with Left Right buttons and Middle wheel/button. Do you know if there are any keyboard shortcuts that I could use in KDE to get to Yast?

Maybe I should start another thread!...
 
Old 05-11-2004, 07:41 PM   #6
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Okay worked out the keyboard shortcuts and mouse (although without wheel) is working again, so back to Nvidia...
 
Old 05-11-2004, 08:14 PM   #7
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Okay, working at last! Thanks a lot, any chance you could explain what it was I just did?!...
 
Old 05-12-2004, 01:10 PM   #8
squid69
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
With suse the 3d wont work unless you do the above but this even includes 9.1 even though when you install it say`s 3d is enabled you still have to go to init 3 to save it.

You have just exited the X86 gui (I think) and enabled 3d in text mode through sax2 ?

Got it.................................No me neither
 
Old 05-12-2004, 03:40 PM   #9
mawooshen
LQ Newbie
 
Registered: Apr 2004
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 10 & NVidia Graphics Drivers mechanical-nucleus Linux - Hardware 3 12-02-2005 08:39 PM
Wide Screen & nVidia GeForce FX Go5200 luca.naso Linux - Laptop and Netbook 6 04-01-2005 02:27 AM
Nvidia Geforce FX go5200 Errors wcujoe Linux - Hardware 2 01-26-2005 10:21 AM
Problems with XFree86 and nVidia Geforce FX Go5200 nblue Linux - Laptop and Netbook 4 05-12-2004 07:34 AM
Suse & NVIDIA Graphics card problem HELP! redcelica67 Linux - Newbie 3 01-25-2004 08:54 PM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration