LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Not able to install gcc (Centos 5.10) (http://www.linuxquestions.org/questions/linux-distributions-5/not-able-to-install-gcc-centos-5-10-a-4175488810/)

just.srad 12-21-2013 08:15 PM

Not able to install gcc (Centos 5.10)
 
Hi.. i am using CentOS 5.10

i try to install the package gcc using yum using the following command:

#yum install gcc

And got the error:

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gcc.x86_64 0:4.1.2-54.el5 set to be updated
--> Processing Dependency: glibc-devel >= 2.2.90-12 for package: gcc
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.5-118 set to be updated
--> Processing Dependency: glibc = 2.5-118 for package: glibc-devel
--> Processing Dependency: glibc-headers = 2.5-118 for package: glibc-devel
--> Processing Dependency: glibc-headers for package: glibc-devel
--> Running transaction check
---> Package glibc-devel.x86_64 0:2.5-118 set to be updated
--> Processing Dependency: glibc = 2.5-118 for package: glibc-devel
---> Package glibc-headers.x86_64 0:2.5-118 set to be updated
--> Processing Dependency: glibc = 2.5-118 for package: glibc-headers
--> Finished Dependency Resolution
glibc-devel-2.5-118.x86_64 from centos has depsolving problems
--> Missing Dependency: glibc = 2.5-118 is needed by package glibc-devel-2.5-118.x86_64 (centos)
glibc-headers-2.5-118.x86_64 from centos has depsolving problems
--> Missing Dependency: glibc = 2.5-118 is needed by package glibc-headers-2.5-118.x86_64 (centos)
Error: Missing Dependency: glibc = 2.5-118 is needed by package glibc-devel-2.5-118.x86_64 (centos)
Error: Missing Dependency: glibc = 2.5-118 is needed by package glibc-headers-2.5-118.x86_64 (centos)

You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest



But when i tried to install glibc package -> yum install glibc, and i got the following errors:

Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
* rpmforge: mirror.oscc.org.my
Setting up Install Process
Package matching glibc-2.5-118.x86_64 already installed. Checking for update.
Package matching glibc-2.5-118.i686 already installed. Checking for update.
Nothing to do

In that error message, we can see that glibc-2.5-118x86_64 has already installed . And why did yum complains that
about "Missing Dependency: glibc = 2.5-118 is needed by package glibc-devel-2.5-118.x86_64 (centos)" (in the first error message above)
when i did the "yum install gcc".

Thanks in advance for any feedback that would help in resolving this.

Justin

John VV 12-22-2013 01:19 PM

please read the centos wiki

and use the groupinstall

Code:

su -
yum groupinstall "Development Tools" "Development Libraries"

and double check the names from the output od
Code:

su -
yum grouplist


also you have " rpmforge" installed on CentOS 5 / RHEL 5
rpmforge is KNOWN !!!!!!!!!!
to have many ,many , many incompatible rpms that are incompatible with the redhat/cent base and update repos
and you do not have "yum-priorities " installed and configured
see:
http://wiki.centos.org/AdditionalResources/Repositories
and heed the warnings
the yum plugin
http://wiki.centos.org/PackageManagement/Yum/Priorities

this was "? mostly ?" fixed in CentOS 6



Also have you cleaned the database
Code:

su -
yum clean all
rpm --rebuilddb
yum update


just.srad 12-23-2013 07:48 PM

Thanks John.. That's really informative. Appreciate it! =)


All times are GMT -5. The time now is 01:23 PM.