LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 02-08-2007, 03:16 AM   #1
vadivelsurya
LQ Newbie
 
Registered: Jan 2006
Location: Madurai,India
Distribution: suse 10 and slackware 10.0
Posts: 9
Blog Entries: 1

Rep: Reputation: 0
MySQL not functioning


I,ve installed Ubuntu6.0 and Fedora in two IBM desktops,Slackware 11.0 in assembled Intel(915 chipset) desktop and Open SuSe 10.2 in a Laptop HP Presario 2500.
Xampp was installed in all the above distributions.MySQL is not functioning in Slackware,open Suse and Fedora, but works ok in Ubuntu, when directly logged in as root user. The error is "Error 2002 (HY000) Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)".
Will somebody please help.
 
Old 02-08-2007, 11:22 AM   #2
wpn146
Member
 
Registered: Jan 2005
Distribution: Solaris, Linux Fedora Core 6
Posts: 170

Rep: Reputation: 30
You might want to check: http://www.tech-recipes.com/mysql_tips762.html

Last edited by wpn146; 02-08-2007 at 11:27 AM.
 
Old 02-08-2007, 11:24 AM   #3
cgjones
Member
 
Registered: Nov 2005
Location: Central New York
Distribution: Ubuntu
Posts: 405

Rep: Reputation: 30
I ran into a similar problem on Slackware once. Make sure that MySQL is running, and if it is, have you initialized the base tables that MySQL needs? The following command should set up these tables.
Code:
mysql_install_db
 
Old 02-14-2007, 04:28 AM   #4
vadivelsurya
LQ Newbie
 
Registered: Jan 2006
Location: Madurai,India
Distribution: suse 10 and slackware 10.0
Posts: 9
Blog Entries: 1

Original Poster
Rep: Reputation: 0
mysql solved

Thanks a lot for all who guided. mycnf was edited for the data path (for sock etc)and SQL is working fine.Once again thanks for all.
 
  


Reply

Tags
mysql


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get printers functioning Optiker Ubuntu 5 01-25-2007 09:56 PM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. Dannux Linux - Software 3 03-24-2006 09:44 AM
You must know the windows functioning. RonRice Linux - General 1 09-01-2005 06:19 AM
usb still not functioning synapse Slackware 9 06-12-2004 05:00 PM
Where Are the FUNCTIONING Apps.?? kajensen Linux - General 5 09-06-2003 07:18 PM


All times are GMT -5. The time now is 03:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration