LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 05-29-2009, 07:33 AM   #1
zion_rulz
LQ Newbie
 
Registered: May 2009
Location: India
Distribution: kubuntu-8.04.2
Posts: 12

Rep: Reputation: 0
metasploit frameword 3.2 error


Hi,
I had been using Metasploit Framework on Fedora 10 (Cambridge Release) for sometime now with ruby-1.8.6.287-2; However, recently I upgraded ruby to ruby-1.9.1 and metasploit stopped working. Not sure, why this happened. Screenshot for ref. Any help / suggestions will be appreciated.

[root@9005LTPGEN0142 framework-3.2]# ./msfconsole
/home/Parizaa/Download/framework-3.2/lib/msf/core/exploit.rb:229:in `require': /home/Parizaa/Download/framework-3.2/lib/msf/core/exploit/smb.rb:401: invalid multibyte char (US-ASCII) (SyntaxError)
/home/Parizaa/Download/framework-3.2/lib/msf/core/exploit/smb.rb:401: syntax error, unexpected tIDENTIFIER, expecting ')'
Rex::Text.to_unicode('T�voli nyomtat�k')
^
/home/Parizaa/Download/framework-3.2/lib/msf/core/exploit/smb.rb:401: invalid multibyte char (US-ASCII)
from /home/Parizaa/Download/framework-3.2/lib/msf/core/exploit.rb:229:in `<class:Exploit>'
from /home/Parizaa/Download/framework-3.2/lib/msf/core/exploit.rb:28:in `<module:Msf>'
from /home/Parizaa/Download/framework-3.2/lib/msf/core/exploit.rb:3:in `<top (required)>'
from /home/Parizaa/Download/framework-3.2/lib/msf/core.rb:48:in `require'
from /home/Parizaa/Download/framework-3.2/lib/msf/core.rb:48:in `<top (required)>'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui/console/driver.rb:1:in `require'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui/console.rb:10:in `require'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui/console.rb:10:in `<top (required)>'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui.rb:10:in `require'
from /home/Parizaa/Download/framework-3.2/lib/msf/ui.rb:10:in `<top (required)>'
from ./msfconsole:12:in `require'
from ./msfconsole:12:in `<main>'
 
  


Reply

Tags
framework, metasploit, ruby


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Portrait: Metasploit godfather H.D. Moore LXer Syndicated Linux News 0 10-30-2008 10:50 PM
LXer: Metasploit 3.2 Goes Open Source and Gets More Evil LXer Syndicated Linux News 0 10-09-2008 08:41 AM
metasploit dellthinker Linux - Software 0 01-21-2007 05:49 PM
Metasploit & Nessus games1 Linux - Software 1 10-05-2006 05:24 AM
LXer: Fear the Metasploit Framework LXer Syndicated Linux News 0 09-27-2006 02:33 PM


All times are GMT -5. The time now is 11:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration