LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 03-10-2003, 08:55 AM   #1
luap
Member
 
Registered: Feb 2003
Location: atlanta ga usa
Distribution: suse 8.2
Posts: 78

Rep: Reputation: 15
Question lsmod in redhat 8.0


hello,
can anyone tell me the correct way to get to modules in redhat 8.0? i think the command is lsmod, done as root, but thats not working, is there a particular path, or directory, that i should be lsmodding from?
i am trying to fix my soundcard-redhat has picked up my sb live and also the integrated sound from my mobo. this is a dual boot with xp, sb live working fine under xp. i checked bios, no setting to disable onboard sound, so i'm thinking maybe redhat gets no sound due to conflict-maybe remove module for integrated sound,
then maybe try the permissions fixes noted in other threads. i have tried sndconfig, checked volume settings.
i saw a post to disable pnp in bios and that might fix sb live in redhat, but wouldnt disabling pnp cause a problem for xp?
thanks in advance-
 
Old 03-10-2003, 10:04 AM   #2
Smerk
Member
 
Registered: Oct 2002
Location: Cairnsian, Oz
Distribution: Debian testing/unstable, knoppix/debian fudged router!
Posts: 169

Rep: Reputation: 30
this mebbe a really dumb thing to say but..
are you typing lower case L for lsmod?
 
Old 03-10-2003, 05:08 PM   #3
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
lsmod will list the modules the kernel has loaded
They are stored in the /lib directory and subdirectories.

There is a SBLive site for Linux,
http://home.wanadoo.nl/whatdoya/sblive/index4.html
 
Old 03-10-2003, 08:35 PM   #4
luap
Member
 
Registered: Feb 2003
Location: atlanta ga usa
Distribution: suse 8.2
Posts: 78

Original Poster
Rep: Reputation: 15
hi, thanks guys for responding.
first, no suggestion is too dumb for me, i'm fairly new to linux.
anyway i did use lower case. and i found my answer. have to do
/sbin/lsmod, not just lsmod. maybe redhat specific?
i double checked my mobo bios-asus a7v333-the board does have on board sound,manual shows setting to adjust, but no setting in bios! pnp is set to no. my hope is to remove the module for onboard sound. but wouldnt linux boot pick up the onboard sound as new hardware ?
thanks again guys!
 
Old 03-11-2003, 12:19 PM   #5
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Rep: Reputation: 55
If you want to add /sbin (or any other directory) to your PATH, type

export PATH=$PATH:/sbin

this will add /sbin to your PATH so you wont have to type the full or relative path with each command. Replace /sbin with any /bin or /home/user/bin etc.
 
Old 03-12-2003, 07:25 AM   #6
luap
Member
 
Registered: Feb 2003
Location: atlanta ga usa
Distribution: suse 8.2
Posts: 78

Original Poster
Rep: Reputation: 15
hi ,
thank you for the tip!
 
Old 03-12-2003, 08:59 AM   #7
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Quote:
Originally posted by luap
hi, thanks guys for responding.
first, no suggestion is too dumb for me, i'm fairly new to linux.
anyway i did use lower case. and i found my answer. have to do
/sbin/lsmod, not just lsmod. maybe redhat specific?
i double checked my mobo bios-asus a7v333-the board does have on board sound,manual shows setting to adjust, but no setting in bios! pnp is set to no. my hope is to remove the module for onboard sound. but wouldnt linux boot pick up the onboard sound as new hardware ?
thanks again guys!
If you want to prevent RH from seeing hardware changes, then stop kudzu from running at boot up.

Cheers--
Charles
 
Old 03-14-2003, 07:53 AM   #8
luap
Member
 
Registered: Feb 2003
Location: atlanta ga usa
Distribution: suse 8.2
Posts: 78

Original Poster
Rep: Reputation: 15
hi, thanks cnjohnson. apparently my mobo has a jumper to disable onboard sound. if that doesnt do the trick, i'll try stopping
kudzu.
 
Old 03-14-2003, 03:47 PM   #9
loran
Member
 
Registered: Jan 2003
Posts: 121

Rep: Reputation: 15
just to piggyback here...
I'm trying to enable my onboard sound but have tried (almost) everything. Can somebody help me diagnose then fix the prob?

2nd: What is "PATH"? I've seen this come up before in Mandrake (I'm Slack now)
 
Old 03-14-2003, 07:15 PM   #10
cnjohnson
Member
 
Registered: Nov 2002
Location: Nashville
Distribution: FreeBSD, Linux, OS-X
Posts: 544

Rep: Reputation: 30
Quote:
Originally posted by loran
just to piggyback here...
I'm trying to enable my onboard sound but have tried (almost) everything. Can somebody help me diagnose then fix the prob?

2nd: What is "PATH"? I've seen this come up before in Mandrake (I'm Slack now)
1. We'll need more information on your mobo and chip set.

2. PATH, this is the list of directories that linux searches through looking for the command that you have asked to be executed. So, when you do a ls, for example, linux finds that in /bin. At a command line, you can type

echo $PATH

and linux will show you where it will look. Often, when you add a command in a directory not in your path, you will have to permanently modify your path so linux can find it. By default, your current working directory is never in your PATH.

Cheers--
Charles
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
lsmod segfault? z-vet Yoper 6 12-15-2004 03:40 PM
lsmod show nothing sesteban Linux - Newbie 6 07-20-2004 01:05 PM
Why can't I use lsmod rmmod etc JohnSharp Linux - Newbie 4 04-08-2004 10:11 AM
Can't Use lsmod/modprobe... lramos85 Linux - Newbie 2 03-08-2004 08:41 PM
lsmod shoot2kill Linux - General 5 04-29-2002 09:42 PM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration