LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 08-05-2004, 05:41 PM   #1
roccoisskad
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Rep: Reputation: 0
login to root goes to yast


hey all!

i tried finding help in other areas for this problem, but it seems that none are of much help. I am dual booting windows xp and suse professional 9.1...i have only one user (myself) and the root. when i login as myself and try to switch users to login as root, i put in root as user, and type in the correct password...and i go straight to YaST! (keep in mind that I have already made root unhidden).

i can access tty1-6 using ctrl+alt+F1-6 and when i try ctrl+alt+F7-12 i only get my session on F7 and the YaST screen on F8.

when i go to tty1 (the somewhat graphical terminal) i am confronted with
linux login:

so i login as root and type my password
where i'm left with
linux:~ #

so i try running startx and get the following error--


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

When reporting an error related to a server crash, please send
the full server output, not just the last messages.
Please report problems to html address here

Xlib: connection to ":0.0" refused by server
Xlib: invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
linux:~ #


i also encounter the same problem if i log out of my session and try logging in...

thanks for the help everyone!
 
Old 08-05-2004, 05:50 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
As for the first part of your question, sounds like 'Administration' is selected as default rather then kde in the session manager. This option runs yast. You just need to select kde or gnome or whatever instead to login to a window manager as root.
 
Old 08-05-2004, 06:11 PM   #3
roccoisskad
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Smile

ooo sounds like that would solve my problem...how do i do that tho!
 
Old 08-06-2004, 03:21 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think you select the session type under the Expert drop down box, But I'm not at my home computer now to check. The drop down box shouldn't be hard to find.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yast Root Login Adriann Suse/Novell 1 03-30-2005 03:03 AM
Root Login -> Yast Snyke Suse/Novell 0 01-05-2005 02:14 PM
only yast at suse root login Tinny Linux - Distributions 1 09-04-2004 01:29 PM
Only Yast when logged in as root fb1907 Linux - Distributions 1 08-25-2004 08:14 PM
login as root just runs YaST mortensent Linux - Newbie 4 08-18-2004 02:28 PM


All times are GMT -5. The time now is 04:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration