LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   login to root goes to yast (http://www.linuxquestions.org/questions/linux-distributions-5/login-to-root-goes-to-yast-213983/)

roccoisskad 08-05-2004 05:41 PM

login to root goes to yast
 
hey all!

i tried finding help in other areas for this problem, but it seems that none are of much help. I am dual booting windows xp and suse professional 9.1...i have only one user (myself) and the root. when i login as myself and try to switch users to login as root, i put in root as user, and type in the correct password...and i go straight to YaST! (keep in mind that I have already made root unhidden).

i can access tty1-6 using ctrl+alt+F1-6 and when i try ctrl+alt+F7-12 i only get my session on F7 and the YaST screen on F8.

when i go to tty1 (the somewhat graphical terminal) i am confronted with
linux login:

so i login as root and type my password
where i'm left with
linux:~ #

so i try running startx and get the following error--


Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

When reporting an error related to a server crash, please send
the full server output, not just the last messages.
Please report problems to html address here

Xlib: connection to ":0.0" refused by server
Xlib: invalid MIT-MAGIC-COOKIE-1 key
giving up.
xinit: unable to connect to X server
xinit: No such process (errno 3): Server error.
linux:~ #


i also encounter the same problem if i log out of my session and try logging in...

thanks for the help everyone!

jschiwal 08-05-2004 05:50 PM

As for the first part of your question, sounds like 'Administration' is selected as default rather then kde in the session manager. This option runs yast. You just need to select kde or gnome or whatever instead to login to a window manager as root.

roccoisskad 08-05-2004 06:11 PM

ooo sounds like that would solve my problem...how do i do that tho! :p

jschiwal 08-06-2004 03:21 PM

I think you select the session type under the Expert drop down box, But I'm not at my home computer now to check. The drop down box shouldn't be hard to find.


All times are GMT -5. The time now is 05:28 AM.