LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   Kubuntu - Is there a way to install all necessary lib files in one shot? (http://www.linuxquestions.org/questions/linux-distributions-5/kubuntu-is-there-a-way-to-install-all-necessary-lib-files-in-one-shot-729249/)

zion_rulz 05-29-2009 03:22 AM

Kubuntu - Is there a way to install all necessary lib files in one shot?
 
I am a noobie and using Kubuntu (Ubuntu 8.04.2).Most of the packages I wish to install shows me unavailability of various lib files. A screenshot for ref.

zion@ubuntu:~$ sudo apt-get install samba smbfs
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
apache: Depends: libdb4.3 (>= 4.3.28-1) but it is not going to be installed
apache-common: Depends: libdb4.3 (>= 4.3.28-1) but it is not going to be installed
Depends: apache2-utils but it is not going to be installed
libgnutls12: Depends: liblzo1 but it is not going to be installed
Depends: libopencdk8 (>= 0.5.7) but it is not installable
Depends: libtasn1-2 (>= 0.2.13) but it is not installable
libldap2: Depends: libsasl2 (>= 2.1.19) but it is not going to be installed
samba: Depends: samba-common (= 3.0.28a-1ubuntu4.7) but 3.0.22-1ubuntu3.8 is to be installed
smbclient: Depends: samba-common (= 3.0.28a-1ubuntu4.7) but 3.0.22-1ubuntu3.8 is to be installed
smbfs: Depends: samba-common (= 3.0.28a-1ubuntu4.7) but 3.0.22-1ubuntu3.8 is to be installed
winbind: Depends: samba-common (= 3.0.28a-1ubuntu4.7) but 3.0.22-1ubuntu3.8 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


I was wandering is there a quick way to install all the lib files required, rather than inidividually.

Any help will be much appreciated.

Thanx.

angel115 05-29-2009 05:55 AM

Hi,

For the 2 library:
Depends: libopencdk8 (>= 0.5.7) but it is not installable
Depends: libtasn1-2 (>= 0.2.13) but it is not installable

I would say it's because you already have an existing (older) version which is in use on your system. so they can't be replaced.


and for the second one, try the following:
Code:

sudo apt-get remove samba-common
sudo apt-get clean
sudo apt-get update
sudo apt-get check
sudo apt-get install samba-common

Angel

zion_rulz 05-29-2009 08:21 AM

Thanks.

I had been able to resolve the issue.

Cheers!


All times are GMT -5. The time now is 04:57 AM.