LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 10-31-2002, 12:47 PM   #1
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Rep: Reputation: 15
KDE Screensaver won't work (Redhat 8)


The KDE screensaver doesn't work on my new Redhat 8 install. I know the individual screensavers exist, because they work fine if you click on the test button (in the screensaver control panel). I tried to set the screensaver to kick in after 3 minutes. However, after 3 minutes the screen just goes blank. Moving the mouse brings up the screensaver password prompt. I assume the problem is a permissions or path problem... any suggestions (including which logs mights have more information) would be greatly appreciated

Please help... I miss my Matrix screensaver!
 
Old 10-31-2002, 03:50 PM   #2
jol
LQ Newbie
 
Registered: Oct 2002
Location: Sydney, Australia
Distribution: Debian
Posts: 3

Rep: Reputation: 0
I've got the same problem on both my RH 8.0 boxes. Don't know of a fix yet. I've had several other problems on 8.0 as well. RH8.0 looks great but.....
 
Old 10-31-2002, 04:27 PM   #3
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Original Poster
Rep: Reputation: 15
Strange

I found where the KDE screensavers are (/usr/bin) and I can run these files no problem. I also tried adding /usr/bin to my path with no effect.

How to check to see if this problem has been reported to Rehat? I tried poking around in Bugzilla but the interface was very confusing...
 
Old 11-01-2002, 12:20 PM   #4
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Original Poster
Rep: Reputation: 15
What package are the KDE screensavers in?

I want to report the bug to Redhat

Anyone know?
 
Old 11-01-2002, 10:11 PM   #5
Zvezda
Member
 
Registered: Jul 2001
Location: Fort Wayne
Distribution: Redhat 9.0, Fedora2
Posts: 87

Rep: Reputation: 15
now that you mention it mine is the same way it blanks out but no screen saver
 
Old 11-03-2002, 07:10 AM   #6
morix
LQ Newbie
 
Registered: Nov 2002
Location: Italy
Distribution: Slackware 9.1
Posts: 4

Rep: Reputation: 0
Question KDE screensaver on Red Hat 8.0

I have the same problem on my RedHat 8.0... javascript:smilie('')
The bug has been reported to RH?
Solutions?

Thanks.
 
Old 11-03-2002, 09:44 AM   #7
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Original Poster
Rep: Reputation: 15
Has it been reported?

I don't know what package the KDE screensaver is in....

If I knew I would check on bugzilla to see if its been reported.
 
Old 11-03-2002, 02:39 PM   #8
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,743
Blog Entries: 4

Rep: Reputation: 76
I too have this problem. Thought I was crazy. I guess the question is: anyone running redhat 8 and the screensavers work?
 
Old 11-03-2002, 04:14 PM   #9
morix
LQ Newbie
 
Registered: Nov 2002
Location: Italy
Distribution: Slackware 9.1
Posts: 4

Rep: Reputation: 0
Lightbulb I got it!

Finally...
Maybe I have the solution!!!

Take a look to http://bugzilla.redhat.com/bugzilla/...g.cgi?id=76760

This is an extract:
-----------------------------------
> You can fix this by creating the following directories under
> $HOME/.kde/share/applnk-redhat:
>
> System/ScreenSavers
>
> Then copy/link all files from /usr/share/apps/kscreensaver/ScreenSavers
>
> You may also have to do the same for the files above the ScreenSavers
> directory.
-----------------------------------

NOW MY RH8 KDE SCREENSAVERS WORK!!!
Let me know if this solution is useful for you too...

Bye.
 
Old 11-03-2002, 04:52 PM   #10
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,743
Blog Entries: 4

Rep: Reputation: 76
Worked like a charm!!! Good one.

I copied them, but I'm sure a ln -s would work too

Last edited by bulliver; 11-03-2002 at 05:00 PM.
 
Old 11-04-2002, 05:30 PM   #11
Rimmer
Member
 
Registered: Feb 2001
Location: 3 million years into deep space
Posts: 42

Original Poster
Rep: Reputation: 15
Thanks

This worked perfectly... thanks
 
Old 11-10-2002, 10:12 PM   #12
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Rep: Reputation: 0
Ha! that did work.. soft link didnt seem to work for some reason for me.

thanks!
 
Old 11-10-2002, 11:18 PM   #13
fritex
LQ Newbie
 
Registered: Nov 2002
Distribution: Red Hat 8.0
Posts: 10

Rep: Reputation: 0
notoneword,
dont use softlink, use this in the
/.kde/share/applnk-redhat/System/ScreenSavers directory:

ln /usr/share/apps/kscreensaver/ScreenSavers/* .

That worked for me
 
Old 11-11-2002, 09:13 PM   #14
notoneword
LQ Newbie
 
Registered: Oct 2002
Location: Twin Cities
Distribution: RedHat 7.3
Posts: 12

Rep: Reputation: 0
fritex... thanks.. hard links works much better than copying all the files over!
 
Old 03-18-2008, 03:59 PM   #15
linuxfan08
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
similar problem but with RHEL 5

Hi-

My KDE screensaver doesn't work either. However, I have RHEL 5 KDE version
3.5.4-13.el5 Red Hat, not Red Hat 8.0. So, the directory structure is not the same. Any fix for Red Hat 5.0?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
screensaver doesnt work encore Slackware 10 09-21-2005 04:43 PM
screensaver wont work Longinus Linux - Newbie 1 02-18-2004 05:25 PM
KDE 3.1 screensavers don't work - RedHat 9 achaudhary Linux - Software 6 01-10-2004 09:24 PM
KDE - screensaver doesn't work nigham Linux - Software 5 10-07-2003 09:29 AM
KDE 3.0.3 ScreenSaver BUG (RedHat 8.0) SoftwareParadis Linux - Software 0 01-05-2003 10:54 PM


All times are GMT -5. The time now is 04:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration