LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Distributions (http://www.linuxquestions.org/questions/linux-distributions-5/)
-   -   How to make Chinese characters display correctly in Gentoo? (http://www.linuxquestions.org/questions/linux-distributions-5/how-to-make-chinese-characters-display-correctly-in-gentoo-234141/)

fossilet 09-23-2004 01:14 AM

How to make Chinese characters display correctly in Gentoo?
 
Hi all,

I intsalled gentoo from stage3. All is OK but I cannot see Chinese Characters well in gnome, mozilla, or the terminal. They are either displayed as ??? or squares containing four hex numbers. All my locale is POSIX. I am wondering if I have to rebuild all my packages to have Chinese support. Someone tells me I have to add +nls +cjk flags and recompile all the packages. Any help will be greatly appreciated.

Regards,

Fossilet

Hitokiri_X 09-23-2004 02:24 AM

I do this in slackware but it should probally work in gentoo also.I would download any international fonts (msgothic,mssong) then make a director in /usr/share/fonts/TTF. Run as root in the font directory /usr/X11R6/bin/mkfontscale,/usr/X11R6/bin/mkfontdir,/usr/X11R6/bin/fc-cache.Then edit your X11F86Config-4 or xorg.conf and add the new font path and you should be able to display international fonts.

fossilet 09-23-2004 06:56 AM

I followed your instructions, Hitokiri. Thanks very much. I can use fcitx to input Chinese and see Chinese web pages. But problem remains when I mount a fat partition with the option iocharset=gb2312. Chinese filenames in the partition still cannot be displayed properly.
BTW: your desktop is cool.

Hitokiri_X 09-23-2004 11:01 AM

I got this from a Faq .

-o nls={NAME}

NTFS stores all file and directory names in Unicode which can represent any character from any language. By default the Linux NTFS driver converts the names to ASCII which is OK for some people, but no good if your languages includes letters like or .

NLS (Native Language Support) controls how characters are displayed. You can choose either utf8 which, like Unicode, can represent all characters, or your own codepage, e.g. iso8859-1 (Western Europe), iso8859-2 (Central Europe), gb2312 (Simplified Chinese), iso8859-8 (Hebrew). Below are some example mount commands:

mount /dev/hda1 /mnt/windows -t ntfs -r -o nls=utf8
mount /dev/hda1 /mnt/windows -t ntfs -r -o nls=iso8859-2
mount /dev/hda1 /mnt/windows -t ntfs -r -o nls=gb2312

Ignore the ntfs parts.Try searching for NLS and you might find a better answer.

Someone got it working it debian here .
Try adding codepage=936 before iocharset=gb2312.

CIO_BlackRainbo 10-31-2004 08:21 AM

You might want to look at http://dev.gentoo.org/~liquidx/chinese/chinese-guide.html.


Or just to install the fonts the gentoo way,

Code:

emerge arphicfonts twmoefonts zh-kcfonts


All times are GMT -5. The time now is 02:38 PM.