LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices



Reply
 
Search this Thread
Old 09-01-2004, 11:00 AM   #1
greythorne
Member
 
Registered: Apr 2004
Posts: 363

Rep: Reputation: 30
help on installing openoffice in suse


hi im trying to install openoffice-1.1.2 in suse as root by issuing "./setup -net" after which as normal user i can issue soffice to have the files installed locally in my home folder. but when i install as root i got this error see below for the error.


cm192:/home/darkstar/OOo_1.1.2_LinuxIntel_install # ./setup -net
glibc version: 2.3.3
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

./setup: cannot connect to X server :0.0

i get this error whenever i try installing as root, but as normal user its goes fine without the error.

any help on this?

thank you.
 
Old 09-01-2004, 10:00 PM   #2
WMD
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware, Debian
Posts: 484

Rep: Reputation: 30
Suse should have RPMs for OpenOffice. No need to use the stock installer.
 
Old 09-01-2004, 11:44 PM   #3
greythorne
Member
 
Registered: Apr 2004
Posts: 363

Original Poster
Rep: Reputation: 30
hmmm, you know i installed the openoffice by logging in as root from there i issued "./setup -net" then logout when in as normal user then "soffice" and it worked, but if i had to do as normal user then su to root it wont work!! then same error as i posted previously.

i want to know what causes this error? is my XF86Config file settings wrong?

thank you.
 
Old 09-02-2004, 09:43 AM   #4
equinox
Member
 
Registered: Dec 2003
Location: Johannesburg, South Africa
Posts: 846

Rep: Reputation: 30
first do xhost +localhost as a normal user, then su to root and run the installer
 
Old 09-02-2004, 09:32 PM   #5
greythorne
Member
 
Registered: Apr 2004
Posts: 363

Original Poster
Rep: Reputation: 30
ok. but im getting the same error, i dont understand-i dont get this in FC1 and FC2.
 
Old 09-04-2004, 12:59 AM   #6
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Try
xhost +

only. This will disable xhost control, so use with care.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing OpenOffice 2.0 from Source dudeman41465 Linux - Software 9 02-17-2006 10:49 AM
Installing Openoffice (frustration) barton Slackware 4 02-18-2005 08:27 AM
Installing OpenOffice problem satimis *BSD 2 04-24-2004 08:55 PM
OpenOffice help- installing new version linuxnewguyT55 Red Hat 4 11-11-2003 12:38 PM
OpenOffice installing Waldi Slackware 1 04-02-2003 06:34 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration