LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices

Reply
 
Search this Thread
Old 03-21-2007, 08:45 PM   #1
svenwinkle
LQ Newbie
 
Registered: Sep 2005
Location: north
Distribution: gentoo
Posts: 23

Rep: Reputation: 15
Gentoo emerge is trying do download an old version that doesn't exist anymore


I am trying to update a number of programs through emerge and am getting an error on one of the programs saying that the file doesn't exist at the ftp site where emerge is trying to download it from. If I go to the site, the file does not exist because there are newer versions available. Is there a way to specify in Gentoo that a newer version of a particular program should be used?

The program I am not able to get is:
file-4.18

Gentoo is trying to get it at:
ftp://ftp.astron.com/pub/file/file-4.18

but only versions 4.19 and 4.20 exist on the ftp site now. Is there a way to tell Gentoo to try version 4.20 instead of 4.18?

Thanks
 
Old 03-21-2007, 09:00 PM   #2
drewbug01
Member
 
Registered: Aug 2006
Location: Detroit!
Distribution: Ubuntu 7.04
Posts: 182

Rep: Reputation: 30
have you synced your portage tree lately? that could be causing it to look for the old version.
Code:
emerge sync
--drew
 
Old 03-21-2007, 09:09 PM   #3
svenwinkle
LQ Newbie
 
Registered: Sep 2005
Location: north
Distribution: gentoo
Posts: 23

Original Poster
Rep: Reputation: 15
I was syncing as I posted that question. Guess I jumped the gun. After a sync it is looking for 4.19 now.

Thanks
 
Old 03-21-2007, 10:10 PM   #4
drewbug01
Member
 
Registered: Aug 2006
Location: Detroit!
Distribution: Ubuntu 7.04
Posts: 182

Rep: Reputation: 30
no problem. good luck!
 
  


Reply

Tags
emerge, gentoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo/Emerge CrazyYoyimbo Linux - Newbie 4 02-15-2005 06:21 PM
pkg-config error with emerge -aD gnome-python on Gentoo 2.6.9-gentoo-r6 ghrellin Linux - Software 2 12-22-2004 06:37 PM
emerge system fails on gentoo install, seven files won't download enigma Z Linux - Distributions 4 08-29-2004 08:00 PM
Please help. Gentoo: Emerge gentoo-dev-sources fails sendas4 Linux - Newbie 3 07-19-2004 11:44 AM
gentoo emerge Treat84 Linux - Networking 1 08-22-2003 11:16 AM


All times are GMT -5. The time now is 10:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration